1

These error just fill my logs:

[316094.848311] [drm:radeon_dvi_detect] *ERROR* DVI-I-1: probed a monitor but no|invalid EDID
[316104.895726] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 128
[316104.898492] Raw EDID:
[316104.901300]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.904245]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.907191]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.910137]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.912948]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.915620]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.918152]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.920589]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.951274] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 128
[316104.953906] Raw EDID:
[316104.956597]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.959421]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.962250]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.965081]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.967907]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.970590]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.973136]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316104.975625]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.006315] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 128
[316105.008953] Raw EDID:
[316105.011641]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.014475]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.017310]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.020144]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.022982]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.025683]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.028234]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.030689]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.061394] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 128
[316105.064038] Raw EDID:
[316105.066736]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.069589]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.072429]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.075263]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.078103]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.080804]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.083339]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.085794]         ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[316105.088272] radeon 0000:0c:01.0: DVI-I-1: EDID block 0 invalid.
[316105.088275] [drm:radeon_dvi_detect] *ERROR* DVI-I-1: probed a monitor but no|invalid EDID

Is there aything I can do to suppress them or tell the driver to probing the monitor or disable DVI port?

I'm running Debian 7 with only a cli as a LAMP server. THere is no GDM nor GUI nor anything like that.

  • Think I found a solution here: forum.proxmox.com/threads/9793-radeon-EDID-error – Frank Barcenas Jul 25 '15 at 3:10
  • Can you remove the AMD video adapter from the machine? They really dislike not having a monitor attached. – Michael Hampton Jul 25 '15 at 3:52
  • NO not really. It's a server in colo. I think it's built into the SUPERMICRO motherboard. – Frank Barcenas Jul 25 '15 at 15:07
  • That's odd, usually they use a cheap Matrox or something rather than a more expensive AMD or NVIDIA GPU. Double check what's actually in the machine. – Michael Hampton Jul 25 '15 at 15:09
  • Yup it's there: 0c:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI ES1000 (rev 02) – Frank Barcenas Jul 25 '15 at 15:35
3

Fix it by: editing /etc/default/grub

# add nomodeset
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

update grub

update-grub

reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.