0

I think this will be a very simple answer from an experienced nix user but unfortunately I am clueless.

I have a CentOS 6.2 server which is not mounting a EXT4 share at boot, it would appear to be caused by data corruption. As a last resort I wanted to run Testdisk to see if anything could be recovered but as I don't have a GUI to work from I am finding it hard to figure out.

I am not sure if it is i386 or x32_64, I would boot from a liveCD but I don't know if that will recognise the storage controller so seeing as the server boots and I have command line I thought I would try to install and run from there.

Any advice would be greatly appreciated.

Thanks

EDIT: After further research I think this is how I can install Testdisk: sudo yum install testdisk

I have not tried this yet but will as soon as we decide if it is worth being sent to a data recovery firm or if I will try Testdisk as a last resort.

  • Some of your terminology is confusing. Please show us the errors rather than describing them. You should consider upgrading your system, it is several revisions out of date. – user9517 Jul 25 '15 at 12:02
  • The system is in the process of being replaced, I am just trying to recover data to move to the new SAN. This morning someone who knows a lot about unix command line connected remotely and it was his opinion that there was some form of data corruption. My last resort was to try and run Testdisk to see if there was anything to recover. Boot log shows: Mounting local filesystems: mount: mount point /mnt/data does not exist – Adam Jul 25 '15 at 12:46
0

Boot log shows: Mounting local filesystems: mount: mount point /mnt/data does not exist

Could be as simple as

mkdir /mnt/data
mount -a
| improve this answer | |
  • I am sure we tried that already but I will try again. – Adam Jul 27 '15 at 9:21
  • @Adam what error messages do you get when you try the mkdir or the mount command? What makes you think you'll need to sent the disk off to a recovery firm? – user9517 Jul 27 '15 at 11:47
  • Hi Iain, I haven't had a chance to try anything else yet but today we accessed our backup store and it seems like we have managed to recover the critical stuff. I am a newb when it comes to linux command line so my opinion was based on the fact we had brought in an outside consultant who tried to mount the share but was unable to. I'm afraid I don't have a note of the exact error but I may try to mount it myself following the advice here as a test. Thanks – Adam Jul 28 '15 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.