7

I am trying to bring up a Centos 6.6 qcow2 image on my virt-manager.

Booting from Hard disk....
Probing EDD (edd=off to disable)... ok

The guest machine stays with the above message for near ten minutes. How can i disable EDD probing in the qcow2 image?

I can see, people's discussion to fix this using boot time setting, linux edd=off. But virt-manager gui doesn't have an interface to set boot options.

Is there any setting, i can tweak after logging into the machine - so that EDD probing may not happen for further logins.

2 Answers 2

4

You don't have to set this in virt-manager.

Add edd=off to the first(!) kernel line inside the VM in /boot/grub/grub.conf, e.g. like so:

kernel /vmlinuz-2.6.32-504.1.3.el6.x86_64 ro root=/dev/mapper/vg01-lv_root rd_LVM_LV=vg01/lv_swap rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto rd_LVM_LV=vg01/lv_root  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet edd=off

I say only to the first line as you can then use an alternative menu entry if this creates problems, and also because the options used in this line will also be used for newer kernels installed by updates.

For a first test, you can also connect to the VM console, either with virt-manager or a VNC client and press e for edit in the Grub boot menu and then add this option to the kernel command line.

5
  • 1
    thanks Sven.. i edited the first kernel line via guestfish... Now Probing EDD message is gone.. But still, the boot time has not come down.. So, it looks like edd is not the culprit and it is possibly due to some other process..... Commented Jul 25, 2015 at 13:39
  • libvirtd.log gets struck for a lot of time at this message, info : virSecurityDACSetOwnership:259 : Setting DAC user and group on '/home/user/images/err.qcow2' to '118:128' Commented Jul 25, 2015 at 13:45
  • Make this a new question, maybe with a link to this one. This is a different problem altogether.
    – Sven
    Commented Jul 25, 2015 at 13:49
  • +1 for this solution. But make sure that the kernel line ends with rhgb quiet edd=off. This worked for me.
    – dr_
    Commented Feb 15, 2016 at 14:18
  • 2
    Note that EDD stands for Enhanced Disk Drive: en.wikipedia.org/wiki/Enhanced_Disk_Drive
    – jhutar
    Commented Nov 6, 2016 at 20:30
8

I had the same symptoms but the problem was that the vmware console wasn't showing the boot output (after the EDD line and a few minutes, the login prompt suddelny appeared) I added

console=tty0 console=ttyS0,115200

..to the grub and next boot all was fine

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .