0

I can't ping my IPv6 from outside and inside of the server, i can't ping any IPv6. My IPv6 : 2001:41d0:2:XXXX::/64

I use CentOS 6.6 with a Xen Kernel that supports IPv6. My provider is OVH and i followed several guides : http://guide.ovh.com/Ipv4Ipv6 and http://www.cyberciti.biz/faq/rhel-re...configuration/ and here my config :

cat /etc/sysconfig/network

...
NETWORKING_IPV6=yes

cat /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
...
IPV6INIT=yes
IPV6_AUTOCONF=no
IPV6ADDR="2001:41D0:2:xxxx::/64"
IPV6_DEFAULTGW="2001:41d0:2:xxff:ff:ff:ff:ff"

cat /etc/sysconfig/network-scripts/route6-eth0

...
net.ipv6.conf.all.autoconf = 0 
net.ipv6.conf.default.autoconf = 0 
net.ipv6.conf.eth0.autoconf = 0
net.ipv6.conf.all.accept_ra = 0 
net.ipv6.conf.default.accept_ra = 0 
net.ipv6.conf.eth0.accept_ra = 0
net.ipv6.conf.all.accept_redirects=0 
net.ipv6.conf.all.router_solicitations=1
net.ipv6.conf.default.proxy_ndp=1
net.ipv6.conf.all.proxy_ndp=1 
net.ipv6.conf.default.forwarding=1
net.ipv6.conf.all.forwarding = 1

Network restart : service network restart

i add a route : route -A inet6 add default gw 2001:41d0:2:xxff:ff:ff:ff:ff dev eth0

Ip6tables is disabled.

ifconfig -a

eth0      ...
          inet6 addr: 2001:41d0:2:xxxx::/64 Scope:Global
          inet6 addr: fe80::230:48ff:fefd:7a86/64 Scope:Link

traceroute ipv6.google.com

traceroute to ipv6.google.com (2a00:1450:4007:80d::200e), 30 hops max, 80 byte packetsping ipv6.
 1  2001:41d0:2:xxxx::)  3005.167 ms !H  3005.118 ms !H  3005.089 ms !H

ping ipv6.google.com

ping: unknown host ipv6.google.com

Ping from an IPv6 failed too.


I change IPv6 like that : 2001:41d0:2:XXXX::1234/64

I have one file for IPv6 routes :

cat /etc/sysconfig/network-scripts/route6-eth0

2001:41D0:2:xxff:ff:ff:ff:ff dev eth0
default via 2001:41D0:2:xxff:ff:ff:ff:ff

I restarted the network service and i get this warning message :

service network restart

Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]

Global IPv6 forwarding is disabled in configuration, but not currently disabled
in kernel

Please restart network with '/sbin/service network restart'

WARN : [ipv6_add_route] 'No route to host' adding route '::/0' via gateway ' 2001:41d0:2:xxff:ff:ff:ff:ff' through device '' [ OK ]

ping6 2001:41d0:2:xxff:ff:ff:ff:ff

PING 2001:41d0:2:xxff:ff:ff:ff:ff(2001:41d0:2:xxff:ff:ff:ff:ff) 56 data bytes

From 2001:41d0:2:xxxx::1234 icmp_seq=1 Destination unreachable: Address unreachable

  • 1
    It's not part of the solution but the command you should be using is ping6. Attempting to ping an IPv6 only host like ipv6.google.com will return an unknown host error. – user9517 supports GoFundMonica Jul 28 '15 at 17:00
  • I tried to run a traceroute to 2001:41d0:2:XXXX::1234, but it didn't work. I think you may have mistyped the address in the question. If you fix that, then we can better help you. – kasperd Jul 29 '15 at 6:01
1

The address 2001:41d0:2:XXXX::/64 has an all-zero host part. Try assigning a proper address, eg. 2001:41d0:2:XXXX::YYYY/64.

Before you try pinging a host on the Internet like ipv6.google.com, check if you can ping the default gateway by its numeric address 2001:41d0:2:xxff:ff:ff:ff:ff.

Also check if XXXX == xxff in the above addresses. Otherwise your CentOS machine won't be able to reach the default gateway, at least not without the additional route command given on the OVH guide page.

  • The address 2001:41d0:2:XXXX::/64 has an all-zero host part - And what is the problem with that? It seems to work fine for me? – Zoredache Jul 28 '15 at 16:21
  • According to RFC 5453 the all-zero interface identifier is reserved for Subnet-Router Anycast and MUST NOT be used for autonomous autoconfiguration or for managed address configuration. – Tilman Schmidt Jul 28 '15 at 16:30
  • I've never managed to get OVH's nonstandard "default gateway" to work properly. I've always just pinged ff02::2%enp3s0f0 and used whatever came back as the default gateway, which does work. – Michael Hampton Jul 28 '15 at 18:57
1

As Tilman Schmidt already pointed out, you have an all-zero host part. However, I also had trouble enabling IPv6 in an LXC container. This worked for me on CentOS 7:

In /etc/sysconfig/network-scripts/ifcfg-eth0, add:

IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=yes
IPV6ADDR_SECONDARIES="2001:41D0:2:xxxx::1/64"

(remove redundant lines, obviously)

For me it wasn't necessary to run route, edit route6-eth0 or change sysctl values. Just setting the primary address as secondary address does the trick. I tested this both with NetworkManager on and off.

Sorry that I cannot offer an explanation on why this happens. It just looks like the network configuration in CentOS 7 on LXC ignores static configured IPv6 and doesn't get an address from router advertisements. I have observed the same problem on Debian Wheezy (although I don't have a solution for that one).

0

Did you ever get it to work? If you didn't, change your IPv6 address from

IPV6ADDR="2001:41D0:2:xxxx::/64"

to

IPV6ADDR="2001:41D0:2:xxxx::/56"

then restart your network interface with service network restart. Test if your IPv6 gateway is now reachable with ping6 2001:41d0:2:xxff:ff:ff:ff:ff.

OVH IPv6 guides are misleading and I encountered the same problem until I noticed they got the prefix length wrong to accommodate their IPv6 gateway setting.

References: http://blog.nirkabel.org/2018/05/14/vmware-esxi-on-ovh-coms-dedicated-server-additional-ipv4-subnet-and-native-ipv6-connectivity/

  • As with your other answer, the prefix /64 is correct. This guy's use of /56 is a pretty bad workaround for his inability to configure a static route in ESXi. – Michael Hampton May 15 '18 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.