1

After installing an SSL certificate from Comodo following these instructions, I've found that apache will no longer start. This is my config:

<VirtualHost *:80>
    ServerName latimer.io
    ServerAlias *.latimer.io
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/latimer.io/html

#       RewriteEngine On
#       RewriteCond %{HTTPS} off
#       RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
</VirtualHost>

<VirtualHost *:443>
    ServerName latimer.io
    ServerAlias *.latimer.io
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/latimer.io/html

    SSLEngine On
    SSLCertificateKeyFile /etc/ssl/server.key.secure
    SSLCertificateFile /etc/ssl/latimer_io.crt
    SSLCertificateChainFile /etc/ssl/latimer_io.ca-bundle
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Apache error log gives the following (not very helpful) errors:

[ssl:emerg] [pid 30910] AH02240: Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)
[ssl:emerg] [pid 30910] AH02312: Fatal error initialising mod_ssl, exiting.

Yet running apache2ctl -S produces no errors. Any guidance as to how to proceed is appreciated. Other serverfault pages describing the same, generic error have not been successful in resolving the problem.

closed as too broad by Jenny D, Ward, kasperd, mdpc, womble Aug 3 '15 at 5:24

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

I reinstalled apache and the problem was fixed. Something must have been corrupted.

Not the answer you're looking for? Browse other questions tagged or ask your own question.