2

I have created a Virtual Network on Azure and have created two VM's within the Virtual network, with IP's 10.0.0.4 and 10.0.0.5. I have added Active Directory role to a one of the VM's and promoted it to Domain Controller role. I am trying to the other VM to the existing domain (mydomain.com) but I get an error stating that the "AD Domain Controller could not be contacted". What may be the cause of this? I checked that the Gateway and Subnet mask of the two servers match.

  • Is the other VM using the new DC for DNS? If not, then that's probably the problem. – joeqwerty Jul 29 '15 at 20:00
  • i haven't set anything like that. how can I do that? even the DC obtains DNS automatically – Gaurav Jul 29 '15 at 20:02
  • i checked the ipv4 dns address in the network properties. they are the same on both servers – Gaurav Jul 29 '15 at 20:10
  • That doesn't tell me anything. Are they both set to use the DC for DNS? If not, then that's the problem. AD members should not use public DNS servers for DNS. They should only use AD DNS servers for DNS. – joeqwerty Jul 29 '15 at 20:13
2

It sounds like your DNS configuration is the problem.

On the DC use the DC's actual ip address as the preferred DNS server and use 127.0.0.1 as the secondary DNS server. On the client use the DC's actual ip address as the primary DNS server and leave the secondary DNS server blank.

0

You control DNS for the network in network settings.

  1. Make sure your DC has a static internal ip address so that it doesn't aquire a new ip address upn reboot
  2. In the virtual network settings in the azure portal (you need to do this using manage.windowsazure.com afaik) configure the vnet's DNS to point to your DC's static internal ip address
  3. Reboot your to-be-member server. Running ipconfig on it should confirm that it now uses the DC as its DNS server and you shoulw be able to go ahead and join it to the domain.
  4. For some reason external domains resolve a bit fishy when set up like this, so it's a good idea to set up a forwarder on your DC's DNS server to point to some well-known public dns such as 8.8.8.8 for instance.
0

Do not adjust the DNS or DHCP properties of your VMs in Azure. You just need to make sure that the virtual network you created in Azure has your internal IP address of the domain controller listed. In this case, 10.0.0.4. This way your second machine can located the first DC to join the domain.

From that point on, your DC will be responsible for resolving all DNS requests, just like it would have to do on an on-prem network.

0
  1. Please make sure you dont make any changes to IP/DNS records inside VM. If you do you will not longer be able to RDP to the machine and have to re-built it.
  2. Solution is very simple. Go to AZURE portal and select the VNET to which the CLIENT(END POINTS) belongs. Go to DNS and change it from Microsoft DNS to Custom and put the IP of the Domain controller.
  3. save the settings and reboot the machine in that VNET. 4.Try to add to the domain again and it will work.
0

In Azure VNet you have to set a Custom DNS server to your DC which is 10.0.0.4. So go to the network interface --> DNS servers --> Custome --> Private IP of DNS and save

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.