1

After migrating 50 mailboxes from SBS 2008 / Exchange 2007 to Office 365, we are finding that some Outlook 2013 clients are trying to connect to the old Exchange server.

I think this is related to internal DNS, resolving domain.com to the domain controller instead of externally.

Can someone please suggest a fix for this?

We can't disable the Exchange 2007 server yet as mail is still migrating using MigrationWiz.

3

Outlook, uses "Autodiscover" to find out where the user mailbox is, as long as you have Exchange server running in your network, the users will always be pointed to that server before anything.

There are different stages for autodiscover, listed here according to the order Outlook uses them:

  1. SCP lookup: Exchange will save some helpful information for Outlook inside Active Directory, Outlook will query that information to find out where the user mailbox is.
  2. HTTPS root domain query: Outlook will run a query to the domain name the user is using, for exmaple: https://testdomain.com/autodiscover/autodiscover.xml
  3. HTTPS Autodiscover domain query: Outlook will add the domain "autodiscover" to the HTTPS root domain query: https://autodiscover.testdomain.com/autodiscover/autodiscover.xml.
  4. HTTP redirect method for any of the links above.
  5. SRV record query stored in DNS.
  6. Local XML file configured by the admin.
  7. Cached URL in the Outlook profile.

I would start with the SCP lookup method, as usually this is the default method for Outlook to find its mailbox inside a domain, you will need to disable that using the following steps:

  • Open Exchange Management Shell "EMS"
  • Run the command "Get-ClientAccessServer": this will list the Client Access Server "CAS" configured in your domain.
  • Run the command "Set-ClientAccessServer -Identity "CASName" -AutoDiscoverServiceInternalUri $NULL" to clear the SCP lookup information from the domain, where CASName is the result of the Get-ClientAccessServer command.

IMPORTANT NOTE: running this command will disable user access to the internal mailbox, you will need to configure each user who have their mailbox still hosted in the internal Exchange server manually.

  • Thanks! Clearing the SCP lookup worked. Outlook immediately connected to Office 365 instead of the local Exchange. – Ash Aug 18 '15 at 23:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.