8

I have a domain joined HyperV Server Core 2012 R2 machine, and a domain joined service is enabled and allows access from this computer. By default, the WinRM firewall exception for public profiles limits access to remote computers within workstation which was in-place upgraded from Windows Pro 8.1 to Windows 10 Pro. Prior to the update I was able to use Hyper-V Manager to connect to the 2012 R2 server to manage the VMs on that machine. After the update I get this error:

[Window Title]
Hyper-V Manager

[Main Instruction]
An error occurred while attempting to connect to server "HYPERV01". Check that the Virtual Machine Management service is running and that you are authorized to connect to the server.

[Content]
The operation on computer 'HYPERV01' failed: WinRM cannot complete the operation. Verify that the specified computer name is valid, that the computer is accessible over the network, and that a firewall exception for the WinRM the same local subnet.

[Close]

The workstation and server are on the same subnet, and I checked that Remote Management and some other Hyper-V exceptions are enabled in the firewall. How to I correct this?

EDIT: I'm not sure anymore if the Win10 update had anything to do with it. By entering the first command on the accepted answer on the hyperv server, i was able to connect again via the Hyper-V manager in Windows 10 with no other changes (not even the winrm set command was needed). So it could be that a recent Windows Update on the server reset the firewall rules, as enter-psssession hyperv01 was also failing, I later discovered.

6

You will need to enable the use of WinRM to connect to your Hyper-V server. To do this you will need to:

Open the Start menu Click on All Programs and then on Accessories Right click on Command Prompt and select Run as administrator Type in winrm quickconfig and hit enter. You will then need to say ‘y’ (yes) to a couple of prompts

Type in: winrm set winrm/config/client '@{TrustedHosts="RemoteComputerName"}' and hit enter. Substitute "RemoteComputerName" with the name or IP address of your Hyper-V server.

After the Windows 10 upgrade you have to re-authorize the Hyper-V server again. That's it.. resolved.

the command line entry was missing the single quotes around @{TrustedHosts="RemoteComputerName"}. it needs to be '@{TrustedHosts="RemoteComputerName"}'

| improve this answer | |
  • Are these companiesmmands on the client or server? Why did i not have to do this originally? – Andy Aug 2 '15 at 21:00
  • Ok, I have no idea why (maybe a recent Windows update on the server), but runing winrm quickconfig prompted me to allow firewall exceptions after saying they were not, and answering Y fixed this. So perhaps this had nothing to do with my updating to Win10 and had to do with the last batch of updates. The winrm set command for me was not needed at all. I decided to try this after I discoverd that enter-pssession hyperv01 was also failing, where it had been working previously. – Andy Aug 3 '15 at 13:18
  • I had the same issue with non-domain situation, the command: winrm set winrm/config/client @{TrustedHosts="RemoteComputerName"} resolved my issue, but each time I reboot the Win 10 client, I need to retype it again to make connection to the remote host, any idea ? – Sami-L Feb 9 '16 at 23:13
  • 1
    Does not work, it reports back "Error: Invalid use of command line." – Brian Knoblauch Oct 2 '18 at 15:36
0

I updated to windows 10 as well and suffered the same issue, When I read your post it occurred to me I wasn't logged onto the domain. Windows 10 reverted back to a local user account for sign-in.

Once I logged in on the domain my issue was resolved, I hope this helps.

| improve this answer | |
  • Sorry but that's not my issue. – Andy Aug 1 '15 at 17:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.