0

i'm trying to install the mongo.so extension but it fails.

According to PHP Mongo Installation manual, i should run :

sudo pecl install mongo

tho i get this error :

downloading mongo-1.6.10.tgz ... Starting to download mongo-1.6.10.tgz (209,087 bytes) ............done: 209,087 bytes 118 source files, building running: phpize sh: 1: phpize: not found If the command failed with 'phpize: not found' then you need to install php5-dev packageYou can do it by running 'apt-get install php5-dev' as a root userERROR: `phpize' failed

so i try :

sudo apt-get install php5-dev

then in return i get this error: Sorry it's in french but basically php5-dev has unsatistied dependencies ...

Les paquets suivants contiennent des dépendances non satisfaites : php5-dev : Dépend: autoconf (>= 2.63) mais il n'est pas installable Dépend: automake (>= 1.11) mais il n'est pas installable Dépend: libssl-dev mais ne sera pas installé Dépend: libtool (>= 2.2) mais il n'est pas installable Dépend: shtool mais il n'est pas installable Recommande: pkg-php-tools mais il n'est pas installable E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Please note that php-cli and php-pear are properly installed.

But apt-get update fails too : Again in french... means the download of index files failed, they been ignored, etc...

Atteint http: //fr.archive.ubuntu.com trusty-backports/universe Translation-en
4 182 ko réceptionnés en 36s (115 ko/s)
W: Impossible de récupérer http:// fr.archive.ubuntu.com/ubuntu/dists/trusty/Release Impossible de trouver l'entrée « restricted/source/Sources » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Just in case, my sources.list :

    #------------------------------------------------------------------------------#
#                            OFFICIAL UBUNTU REPOS                             #
#------------------------------------------------------------------------------#


###### Ubuntu Main Repos
deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse

###### Ubuntu Update Repos
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

###### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

#------------------------------------------------------------------------------#
#                           UNOFFICIAL UBUNTU REPOS                            #
#------------------------------------------------------------------------------#


###### 3rd Party Binary Repos

#### MongoDB - http://www.mongodb.org/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 7F0CEB10
deb http://downloads-distro.mongodb.org/repo/ubuntu-upstart dist 10gen
  • You can (and probably should) get English equivalent error messages by prefixing your apt-get commands with LANG=en_US -- so, for example, LANG=en_US apt-get update. The exact text of error messages is often very importan for diagnosing a problem like this. – womble Aug 1 '15 at 20:36
  • @womble Incredible!!! I did what you suggested in order to update my post with the english error messages, but then it worked. I'm not sure why changing the output language changes the output itself, but it simply did !!! – Laurent Demouge Aug 2 '15 at 12:09
  • @womble don't hesitate to put your comment as answer so i can accept it – Laurent Demouge Aug 2 '15 at 12:12
  • I didn't answer your question, your problem fixed itself. My guess would be the local mirror was down originally, and then it came good and the packages needed to satisfy the dependency were suddenly available. But that's just a guess. – womble Aug 2 '15 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.