1

I try to rsync a folder from server A to server B:

rsync -aAXSHPr --numeric-ids --fake-super --delete --delete-after --delete-excluded -e "ssh -i key" root@1.2.3.4:/home/vmail/ /home/vmail/

rsync -avz --numeric-ids --fake-super --delete --delete-after --delete-excluded -e "ssh -i key" root@1.2.3.4:/home/vmail/ /home/vmail/

No matter how I try rsync does not set the vmail owner on certain files (leaves them owned by root). I don't interrupt the process, I know it should do it at the end.

The vmail user has the exact same UID on both servers. I can of course chown the files after rsyncing.

What can go wrong here?

0

As you seem to be root I dont know why you are using --fake-super. You should try removing it.

I've never used the option, but reading the man page seems to suggest when using --fake-super you are also supposed to use -M--fake-super so it is applied at both ends.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.