1

Enable ExecShield protection - ExecShield is security Linux kernel patch to avoid worms and other problems.

After Adding to

/etc/sysctl 
kernel.exec-shield = 1

Getting this error sysctl: cannot stat /proc/sys/kernel/exec-shield: No such file or directory

Output :

root@ashishk:/home/ashish/MyScripts# sysctl -p

sysctl: cannot stat /proc/sys/kernel/exec-shield: No such file or directory

kernel.randomize_va_space = 1

net.ipv4.conf.all.rp_filter = 1

net.ipv4.conf.default.rp_filter = 1

net.ipv4.icmp_echo_ignore_broadcasts = 1

net.ipv4.conf.all.accept_source_route = 0

net.ipv4.conf.default.accept_source_route = 0

net.ipv4.conf.all.send_redirects = 0

net.ipv4.conf.default.send_redirects = 0

net.ipv4.tcp_syncookies = 1

net.ipv4.tcp_max_syn_backlog = 2048

net.ipv4.tcp_synack_retries = 2

net.ipv4.tcp_syn_retries = 5

net.ipv4.conf.all.log_martians = 1

net.ipv4.icmp_ignore_bogus_error_responses = 1

net.ipv4.conf.all.accept_redirects = 0

net.ipv4.conf.default.accept_redirects = 0

net.ipv4.icmp_echo_ignore_all = 1

net.ipv6.conf.all.disable_ipv6 = 1

net.ipv6.conf.default.disable_ipv6 = 1

net.ipv6.conf.lo.disable_ipv6 = 1

Can i know what is wrong ?

  • please can you provide what distribution you are using? maybe you are using a new distribution, exec-shield is present in redhat 5 and I don't this problem, but maybe is deprecated in the newers distro. – c4f4t0r Aug 3 '15 at 15:21
  • ashish@ashishk:~$ sudo lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty – Ashish Karpe Aug 4 '15 at 6:20
  • I think exec-shield was redhat related, anyway i'm using centos 7 and exec-shield doesn't exist no more, en.wikipedia.org/wiki/Exec_Shield – c4f4t0r Aug 4 '15 at 11:02
  • @c4f4t0r why don't you write your comment as an answer – Ashish Karpe Mar 1 '16 at 9:30
1

c4f4t0r already provided an answer to the immediate question in the comments, but it is not entirely accurate.

exec-shield continues to exist; what actually was removed was the option to disable it through the sysctl setting

https://access.redhat.com/solutions/974563 (link requires a RedHat Subscription. Not providing the exact cite from that link due to copyright concerns).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.