4

I am trying to build the latest version of NTP (4.2.8p3 released on 2015/06/29) with OpenSSL support.

I can definitely build NTP but when I try to use ntp-keygen to create a new certificate it tells me that the parameters are unknown.

I use this command line to create a certificate:

ntp-keygen -p privatePassword -T -I -i GR1

which gives me :

guillaume@quentin-HP-xw6600-Workstation:~/certifs$ ntp-keygen -p privatePassword -T -I -i GR1
/usr/sbin/ntp-keygen: illegal option -- p
ntp-keygen (ntp) - Create a NTP host key - Ver. 4.2.8p3
Usage:  ntp-keygen [ -<flag> [<val>] | --<name>[{=| }<val>] ]...
Try 'ntp-keygen --help' for more information.

I have tried to build ntp with different options but I always have the same issue.

Does someone have the same problem ?

I believe this is a problem with this version of NTP but I am not sure... (I have tried to use the dev version but I got the same result). Or maybe the problem is due to my configure options?

My config options :

./configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--datadir=/usr/share \
--sysconfdir=/etc/ntp \
--disable-linuxcaps \
--enable-parse-clocks \
--disable-ipv6 \
--enable-debugging \
--with-crypto \
--with-openssl-libdir=/opt/opt/openssl/lib \
--with-openssl-incdir=/opt/include/openssl \
--enable-autokey \

Edit : ntp-keygen --help gives me :

guillaume@quentin-HP-xw6600-Workstation:~/certifs$ ntp-keygen --help
ntp-keygen (ntp) - Create a NTP host key - Ver. 4.2.8p3
Usage:  ntp-keygen [ -<flag> [<val>] | --<name>[{=| }<val>] ]...
  Flg Arg Option-Name    Description
   -d no  debug-level    Increase debug verbosity level
                - may appear multiple times
   -D Num set-debug-level Set the debug verbosity level
                - may appear multiple times
   -M no  md5key         generate MD5 keys
      opt version        output version information and exit
   -? no  help           display extended usage information and exit
   -! no  more-help      extended usage information passed thru pager
   -> opt save-opts      save the option state to a config file
   -< Str load-opts      load options from a config file
                - disabled as '--no-load-opts'
                - may appear multiple times

Options are specified by doubled hyphens and their name or by a single
hyphen and the flag character.


The following option preset mechanisms are supported:
 - reading file $HOME/.ntprc
 - reading file ./.ntprc
 - examining environment variables named NTP_KEYGEN_*

Please send bug reports to:  <http://bugs.ntp.org, bugs@ntp.org>

  • What does ntp-keygen --help say? – MadHatter Aug 4 '15 at 11:08
  • @MadHatter I have edited the post with the output of ntp-keygen --help – Guillaume B Aug 4 '15 at 11:19
  • Would you please review your 'code' snippets as they seem to have missing bits. i.e. help does not seem to list the option you specify - configure has a trailing "\" which would suggest another line thereafter at least. FWIW I ran the command on ntp-keygen (ntp) - Create a NTP host key - Ver. 4.2.6p5 and it ran fine: Built against OpenSSL OpenSSL 1.0.1c 10 May 2012, using version OpenSSL 1.0.1e 11 Feb Generating new cert file and link ntpkey_cert_hostname->ntpkey_RSA-MD5cert_hostname.1234831161 – albal Aug 4 '15 at 13:59
  • When I run the command on ntp-keygen I have the same output as you... when I use NTP version 4.2.6. The problem comes up when I try to use the latest version of NTP (4.2.8). For the "\" at the end of the configure, you are right, thanks for that. What do you mean by "Would you please review your 'code' snippets as they seem to have missing bits" ? Thanks for your help – Guillaume B Aug 4 '15 at 14:20
  • For example in your output of the help, where is the text the details what the -T -I -i options do? That is what I mean. You don't get the same output as me @GuillaumeB - or yours would be working. – albal Aug 4 '15 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.