1

My ultimate goal is to install Puppet on a Vagrant CentOS box. The installer is tells me to connect to https://localhost:3000. My host is Windows.

To troubleshoot why I can't connect I started playing around with various options in Vagrant. I played around with the forwarding ports, bridged networking, and at this time I'm on host-only networking. So in my Vagrantfile I have this line:

config.vm.network "private_network", ip: "192.168.33.10"

In the VM I listen on port 8080 like so:

nc -l localhost 8080

From my Windows host I tried to telnet to the 8080 port using various IPs localhost and "192.168.33.10" but nothing works. I've disabled the Windows firewall, the CentOS iptables, everything that I can find on google.

I'm fairly new to networking, can I get some assistance how to troubleshoot this and make it work?

1
0

Don't pass a hostname when using the -l parameter with nc.

nc -l 8080 should do the trick.

1
  • Still same thing. – SBel Aug 5 '15 at 14:13
0

Not really an answer but a check list which is complex to fill in a comment :-)

  1. Make sure you don't have other VMs or actual machines running at the same time with the same IP address. You can test this by turning off the VM you're working on and ping again to 192.168.33.10.

  2. Make sure the virtual interface on the Windows Host is not turned off. By running "ipconfig" you should be able to see an interface with IP address 192.168.33.something.

  3. Make sure from the VM you can ping your Windows Host (you have got the IP from step 2.).

If everything is ok and it's still not working, at least you can edit your original question and add the test results to provide more information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.