8

On one of my domain controllers there are two network interfaces - an external with IPv4 and IPv6 addresses and an Internal with 10.x.x.x address.

The domain controller has RRAS (VPN site-to-site with Azure), DNS and DHCP installed. It replicates with a second DC that is located in Azure VM.

For some reason, the server automatically adds DNS entries for itself for all three IP addresses. If I delete the two public ones, after a while they are back. The network connection properties does not have "Register this connection's addresses in DNS" selected.

The problem I have with this is that AD replication breaks since it tries to connect to the wrong IP (complaining that RPC server is unavailable). If I launch the replication manually after deleting the wrong addresses, it completes successfully.

How to prevent the server from registering the external addresses in DNS?

  • 3
    Don't multi home a domain controller this way. Deploy RRAS on a dedicated server. – MDMarra Aug 6 '15 at 23:17
6

Assuming that this DC is also the DNS server for the AD domain, the DNS server will register every ip address that the DNS server is configured to listen on. If you don't want it to register those ip addresses then uncheck those ip addresses in the properties pages of the DNS server.

enter image description here

2

You need to add the PublishAddresses registry value:

Key: HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters  
Registry Value: PublishAddresses  
Registry Value Type: REG_MULTI_SZ  
Registry Value Data:<IP addresses>  

http://blogs.technet.com/b/ad/archive/2009/04/22/dcs-and-network-address-translation.aspx

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.