2

I've experienced this problem with Intel NUC model NUC5CPYH using both Ubuntu Server 14.04.2 and Ubuntu Server 15.04.

After completing the installation (which in my experience is best done from an external CD drive, as I also had difficulties with installation from USB), the new Ubuntu installation boots but at the point where the screen tries to switch modes (though not to a full GUI, which isn't used by Ubuntu Server) it crashes. The crash appears to be total, not just a display failure. I was using VGA rather than HDMI if this is relevant.

I found a solution - see below.

2
  • I would try restarting the server in single user or "recovery" mode and the post some information from the logfiles in /var/log. If that doesn't work, try booting from the CD, but instead of installing, use the recovery mode and then mount your filesystems to get the logs.
    – Eirik Toft
    Aug 7 '15 at 15:45
  • Thanks for your suggestion. I did try using the Ubuntu recovery mode from CD but it didn't help much. The whole system starts off read-only. I managed to remount /tmp as read-write and then mount the destination system on this (why so difficult?). There was no meaningful info in any logs that I could find. There was no [/tmp/mnt]/var/log/syslog for instance. I did solve my problem in the end - see my answer.
    – gogoud
    Aug 7 '15 at 16:43
1

To boot successfully into Ubuntu Server after completing installation I needed to force it to boot in text mode, but this I found easier said than done. In the end this worked for me:

# boot with SystemRescueCD or similar, which gets to a prompt fine (unlike Ubuntu!)

mkdir /mnt/ubuntu
# assuming your new ubuntu system is installed at /dev/sda1: (check with lsblk)
mount /dev/sda1 /mnt/ubuntu
cd /mnt/ubuntu/boot/grub
# quick'n'dirty fix so we can boot once
sed -ir 's/(set linux_gfx_mode=).*/\1text/' grub.cfg
# that's it, we can try booting into Ubuntu now
reboot

# after successful booting into full Ubuntu system, do:
echo "GRUB_GFXPAYLOAD_LINUX=text" | sudo tee -a /etc/default/grub
# rebuild grub.cfg the 'proper' way
sudo update-grub
# and check that it still works....
reboot

There may be a more elegant way to force a one-time boot in text mode through the boot-time grub menu, but I couldn't find one that worked (suggestions welcome!), hence I am documenting this solution, and hope it helps someone.

I haven't tried installing Ubuntu with a GUI (as I don't need one)...

1

This problem was resolved for me by installing from 14.04.3 release

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.