-1

I installed phpmyadmin using apt-get on a VirtualBox running Debian.

I have uninstalled, reinstalled, added an Include to the apache2.conf, made symlinks, etc, etc.

I ran this : sudo dpkg-reconfigure -plow phpmyadmin to make sure I had ticked apache. No effect.

I ran this :

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo /etc/init.d/apache2 reload

thinking I needed to do things manually, no change.

Also did an aptitude purge phpmyadmin and aptitude install phpmyadmin still nothing.

The only thing that has changed is normally I get a blank html page that says "File not found." If I comment out the Alias in the phpmyadmin.conf I get a normal 404 page. Aside from that, after trying everything I can think of or find nothing has changed.

What am I overlooking?

closed as off-topic by womble, Iain, Jenny D, Michael Hampton Aug 8 '15 at 20:21

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

0

So, as I thought, I was overlooking something.

I should have mentioned that this is a Vagrant box that I didn't create. For some reason, the DocumentRoot in httpd.conf was set to a sub folder of a sub folder. Once I noticed that, the issue became much more clear. Doh!

I had one other issue - when making a symlink for phpmyadmin into the sub/sub folder - on Windows 7, even as an admin, creating symlinks can trigger a "Protocol error." There is information on handling that here

I am self-answering in the hopes that the next person who skips over checking httpd.conf will find this useful.

Not the answer you're looking for? Browse other questions tagged or ask your own question.