1

I have Apache 2.4 set up on a VPS serving 2 virtual hosts (one http and one https) for the same domain. Everything seems to be working fine except for these consistent lines in my apache error log (different pid's of course):

[mpm_itk:error] [pid 31830] child died with signal 11

These mpm_itk errors seem to occur in groups of 5 or 6 roughly every hour and every so often this happens:

[Fri Aug 07 06:25:14.440874 2015] [mpm_prefork:notice] [pid 470] AH00171: Graceful restart requested, doing restart
[Fri Aug 07 06:25:14.513782 2015] [mpm_prefork:notice] [pid 470] AH00163: Apache/2.4.10 (Debian) mpm-itk/2.4.7-02 OpenSSL/1.0.1k configured — resuming normal operations

Both Apache modules mpm_itk and mpm_prefork are enabled in my settings (or is this a problem in itself?).I am wondering if it is safe just to disable mpm_itk and restart Apache? Its a live ecommerce site and I need to be sure before I do anything that may make the problem worse. If anyone has any advice how to safely proceed it would be greatly appreciated.

update

Ok, I have disabled mpm_itk and restarted apache using mpm_prefork. The "mpm_itk errors" are now gone but I am getting these core notices instead :"AH00052: child pid xxxxx exit signal Segmentation fault (11)". Does anyone know what I should be looking at to finally fix this?

  • Why are you using mpm_itk? – Michael Hampton Aug 9 '15 at 2:43
  • It seems to have set itself up in a recent upgrade. Can I safely disable it do you think? – Daryl Aug 9 '15 at 2:45
  • mpm_itk is intended to solve a very specific problem faced by web hosting providers. If you don't know why you have it, you almost certainly don't need it and shouldn't be using it. – Michael Hampton Aug 9 '15 at 2:49
  • Like I say, it was automatically enabled with the upgrade from 2.2 to 2.4. Another module that was enabled was php5filter (instead of the usual php5). I don't know if that was the reason mpm_itk was enabled? If I listed the currently enabled Modules could you, or someone, advise me on which ones to I should be using? Like I say i'm only hosting one Domain on http and https using Virtual Hosts for each. – Daryl Aug 9 '15 at 3:13
  • Ok, I have disabled mpm_itk and restarted apache using mpm_prefork. The "mpm_itk errors" are now gone but I am getting these core notices instead "AH00052: child pid xxxxx exit signal Segmentation fault (11)". Does anyone know what I should be looking at to finally fix this? – Daryl Aug 10 '15 at 5:02
0

Mod ITK crash with incompatible modules, by example: mod security and others. In my case, y try a custom module but when enable it, itk crash with same error message.

Disable other modules and try restart server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.