1

My server: 64 bit Ubuntu 12.04.4 LTS. Provider: Linode.com. No other firewall is present.

I've these rules:

*filter

# Allow localhost traffic. This rule is for all protocols.
-A INPUT -s ::1 -d ::1 -j ACCEPT

-A INPUT -p icmpv6 -j ACCEPT
-A OUTPUT -p icmpv6 -j ACCEPT

#Allow image server
-A INPUT -m tcp  -p tcp  --dport 31333  -j ACCEPT

-A INPUT -m tcp  -p tcp --dport 80 -j ACCEPT
-A INPUT -m tcp  -p tcp --dport 443 -j ACCEPT

COMMIT

The ping is working even from outside. But telnet is not working from localhost.

%  telnet -6 2600:3c00:0:0:f03c:91ff:fe73:2b08 80 
Trying 2600:3c00:0:0:f03c:91ff:fe73:2b08...

What could be the problem?

Ultimately my server will listen on port 31333 for requests from Chrome Browser WebSocket interface. And I want to see telnet on port 80 working first then I'll work on port 31333.

It looks like Apache needs to be bound to 64 bit address. But I've even added this line to see if ftp is working but still telnet can't connect:

-A INPUT -p tcp -m tcp --dport 21 -j ACCEPT

New Trial As per suggestion by Michael Hampton I've run ip6tables -F to clear the rules and now running ip6tables -L shows:

Chain INPUT (policy DROP)
target     prot opt source              destination

Chain FORWARD (policy DROP)
target     prot opt source            destination

Chain OUTPUT (policy DROP)
target     prot opt source           destination

but still connect to port 80 does not work (with IPv4 it works):

# telnet -6 2600:3c00::f03c:91ff:fe73:2b08 80
Trying 2600:3c00::f03c:91ff:fe73:2b08... ^C
# telnet -6 2600:3c00:0:0:f03c:91ff:fe73:2b08 80
Trying 2600:3c00::f03c:91ff:fe73:2b08...

# telnet 23.239.30.81  80 
Trying 23.239.30.81... Connected to 23.239.30.81. Escape character is '^]'.
  • 1
    ::1 is not 2600:2c00::f03c:91ff:f773:2108. I suggest instead of -s ::1 -d ::1 in your localhost traffic rule, you use -i lo. This catches all loopback interface traffic regardless of the addresses involved. – a CVn Aug 9 '15 at 14:31
  • Have you got another firewall somewhere? Exactly what sort of server is this? If you leased it, you should name the specific service provider and product. – Michael Hampton Aug 10 '15 at 15:58
  • @Michael Hampton 64 bit Ubuntu 12.04.4 LTS. Provider: Linode.com. No other firewall is present. – user5858 Aug 11 '15 at 4:56
  • The firewall rule you show is for port 21 (FTP control), while you're testing port 80 (HTTP). Did you really open up port 80 (or test port 21)? – Teun Vink Aug 11 '15 at 5:30
  • 1
    What happens if you turn off the firewall? – Michael Hampton Aug 13 '15 at 4:33
1
+50

Your firewall is configured to drop all traffic, even without any rules. This will be the source of your problem.

Chain INPUT (policy DROP)
Chain OUTPUT (policy DROP)

Reset the policies of these tables to ACCEPT to restore connectivity.

ip6tables -P INPUT ACCEPT
ip6tables -P OUTPUT ACCEPT

Then you can get on with constructing a proper firewall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.