7

Did ESXi 6.0 completely removed the performance data for VMXNET3 or is there is a way, how can enable throughput logging/graphing for VMXNET3?

In ESXi 5.5 the ESXi client showed the network performance data just fine, in the 6.0 I see Network tab in VM Performance only for hw and nonVMXNET3 interfaces.

UPDATE
I see this problem on all servers upgraded with the last ESXi 6.0 release. I cannot do fresh install, but it should be well upgraded. All servers are 2012+ and contain the best possible server hw (Dell / SuperMicro / HP), hw network card, hw raids, mixed CPU types / vendors (Intel E5-xx v2 / AMD).

In VMware KB there is http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2119264 . The vClient do not show "No metrics Specified", but I think they somehow disabled VMXNET3 metrics in ESXi 6.0.


Can someone confirm me the same problem?

Is there is a way, how to get the statistics back?

6

Did ESXi 6.0 completely removed the performance data for VMXNET3 or is there is a way, how can enable throughput logging/graphing for VMXNET3?

No, it's just there in vCenter - if you're not seeing you have an issue, you may need a reinstall.

EDIT - After playing around all day I have to apologise, you're absolutely correct, I don't know what I was thinking - it's clearly a major bug, and one I'll log with them. I've tried this just about every which way I can and you're absolutely correct.

EDIT 2 - I reported this to VMWare, they reproduced the error and have got a fix coming in 6.0U1 out mid-Sept.

EDIT 3 - It got patched and the patch is out as part of 6.0U1 - take a look at the 'Networking Issues' section of the release notes - http://pubs.vmware.com/Release_Notes/en/vsphere/60/vsphere-esxi-60u1-release-notes.html#rnetworkingissues

  • Can you post here a screen with ESXi version and network performance chart for VMXNET3? I just do a successful upgrade and the network performance option is missing for all linux VMs with VMXNET3 drivers. – Mvorisek Aug 10 '15 at 8:21
  • Can you test it with no vCenter, just ESXi client? Can you test if you see network performance data for linux VM (best Debian 8) with VMXNET3 only (as I see hw adapters) network adapter? – Mvorisek Aug 10 '15 at 8:23
  • Do you use the native tools or packages.debian.org/jessie/open-vm-tools or simillar? I am using the open-vm-tools. – Mvorisek Aug 10 '15 at 8:24
  • 1
    Yep, it's broken in both, when I first responded I thought was on a v6 vCSA but it was a v5.5 which threw me, that worked fine but I wanted to be sure so built a small lab setup to prove it and you're right, it doesn't work - I've logged it with vmw though now. – Chopper3 Aug 10 '15 at 22:10
  • 2
    No problem - glad I could help, we're a big vmw client so have their staff to hand all the time to ask, happy to help - good luck with 6.0U1!! – Chopper3 Aug 19 '15 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.