0

I am trying to tunnel the traffic coming from a VPS through a VPN but it doesn't seem to be working.

The current .ovpn file that I am using seems to work just fine on my local machine, but when I launch it on the VPS it just hangs here:

Thu Aug 13 01:23:47 2015 OpenVPN 2.3.2 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [eurephia] [MH] [IPv6] built on Dec  1 2014
Thu Aug 13 01:23:47 2015 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Thu Aug 13 01:23:47 2015 Socket Buffers: R=[212992->131072] S=[212992->131072]
Thu Aug 13 01:23:47 2015 UDPv4 link local: [undef]
Thu Aug 13 01:23:47 2015 UDPv4 link remote: [undef]

I have been googling for hours and can't find an answer, so I am assuming it is simple, but I don't have the experience to answer it on my own.

0

You may get some useful diagnostics out of increasing the logging verbosity (verb 4 seems to be the sweet spot). I think that at low verbosity, the log stopping there means that the client isn't managing to establish any sort of connection to the server, so the first port of call will be to verify the firewalling situation on both ends, and of course wave a bit of tcpdump around to see where packets are and aren't going.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.