0

I have a standard server setup for our application that requires freenx that I have been installing since centos 6.4, on a couple dozen servers. This server was given to me by a new hosting provider with centos 6.7, which I haven't worked on yet. Not sure if that is the problem or not. I'm no expert on linux that's for sure, this might be a problem with mirrors or repos or something else I'm missing?

Update: Packages are no longer available on many mirrors now for some reason

yum clean all
Loaded plugins: fastestmirror, refresh-packagekit, security
Cleaning repos: base extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors
yum install freenx nx
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Determining fastest mirrors
* base: centos.mirrors.atwab.net
* extras: centos.mirror.iweb.ca
* updates: centos.mirror.iweb.ca
base | 3.7 kB 00:00
base/primary_db | 4.6 MB 00:02
extras | 3.4 kB 00:00
extras/primary_db | 26 kB 00:00
updates | 3.4 kB 00:00
updates/primary_db | 770 kB 00:00

No package freenx available.
No package nx available.
Error: Nothing to do


Please assist,
Thank you
Fred

Edit, looks like I'm going through dependency hell now (rpm sucks/im a newbie). Transferred the files to the server from the ATrpms mirror:

yum install libXpm
rpm -i nx-3.3.0-38.el6.x86_64.rpm
yum install nc expect xorg-x11-apps
rpm -i freenx-0.7.1-5.el6.x86_64.rpm
cp /etc/nxserver/node.conf.sample /etc/nxserver/node.conf
nxserver --adduser blah
-bash: nxserver: command not found
rpm -i freenx-server-0.7.3-18.el6.x86_64.rpm
warning: freenx-server-0.7.3-18.el6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 66534c2b: NOKEY
error: Failed dependencies:
/usr/lib/cups/backend is needed by freenx-server-0.7.3-18.el6.x86_64

Stuck at last step now :(

  • It's present in extras. Make sure you don't have any excludes set. – Michael Hampton Aug 13 '15 at 14:53
  • Its available in centOS 6.7? I assume based on above that I'm checking the "extras: centos.mirror.iweb.ca" Not seeing any excludes as far as I can tell in /etc/yum.conf and /etc/yum.repos.d – FredS Aug 13 '15 at 15:02
  • /srv/www/mirrors/centos/6.7/extras/x86_64/Packages/freenx-0.7.3-9.4.el6.centos.x86_64.rpm ... – Michael Hampton Aug 13 '15 at 15:07
  • Should I try forcing the server to use another extras mirror, maybe some known good one? Not sure what to do with that last comment. I want to make sure I get it through yum as I have other packages to install and might run into the same problem with them. – FredS Aug 13 '15 at 15:38
  • That's odd. They're on my mirror but not anyone else's mirror? – Michael Hampton Aug 13 '15 at 15:50
0

On latest CentOS releases (6.6+ and 7.0+) the freenx package is gone. It is replaced by the x2go project/package

  • Thanks for the info, That's terrible, wish they only did that to 7+. If I installed a CentOS 6.6 system and turned off updates would I be able to install nx + free nx? Really don't want to change our processes right now, there are other things we need to take care of first. – FredS Aug 13 '15 at 19:59
  • Also doesn't look like x2go is available in the primary centos repos, is it actually a fully supported/stable replacement to freeNX? – FredS Aug 14 '15 at 13:44
  • It is difficult to state if x2go is a stable replacement for freenx, but it is the project of choice lately. – shodanshok Aug 14 '15 at 13:48
  • Thanks I tried it out and it seems to work well, except for the windows client crashing when I try and open more than 1 connection (2 different servers) – FredS Aug 17 '15 at 18:26
0

According to this CentOS forum post, there is a package group called freenx

According to CentOS FreeNX howto, the packages are default, but there are not present in this mirror (the official one)

So it seems it may has been removed from the official CentOS repos, maybe there is any reference regarding this in changelogs (Still available for CentOS 5 official)

Here you can download the rpm and have the dependencies listed. Still I know is not the ideal approach. Epel don't seem to have the packages, maybe another unofficial repo have them.

  • Yea no group install for it. Stinks, so close to being done with this then I run into this problem :(. All the download links seem to be broken for the rpm download. – FredS Aug 13 '15 at 16:15
  • So most probable packages were referencing to clones of the repo. This repo has it: packages.atrpms.net/dist/el6 and links are working I saw atrpms in the past, but I don't know who maintains it and how trustable is it (not doubting on them, just don't know, but they've been there for long time) You can download the packages or add the repo to your yum lists – ignivs Aug 13 '15 at 16:24
  • Thanks a lot for your help. Can you walk me through the last step of making it available to yum install on my system? Do I need to restart anything after adding the URL to some config file? – FredS Aug 13 '15 at 17:53
  • the site has good information on how to add the repo, here – ignivs Aug 13 '15 at 18:36
  • That helped a lot, now stuck at, for the next step in my setup: nxserver: command not found – FredS Aug 13 '15 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.