0

Before I jump into the issue, I am using RedHat 6.5 and have no access to the internet to download yum updates due to environment restrictions. All I have in this case is the CD ROM (RHEL 6.5) to utilize. After the image is updated, we utilize an internet server to pull updates but prior the server needs to be able to stand on its own.

On the image I need to utilize ldapsearch, so I did a yum whatprovides */ldapsearch to figure out which package to install.

I received:

openldap-clients-2.4.23-32.el6_4.1.x86_64 : LDAP client utilities
Repo        : cdrom
Matched from:
Filename    : /usr/bin/ldapsearch

When I go to install this package:

[root@test1 yum.repos.d]# yum install openldap-clients-2.4.23-32.el6_4.1.x86_64
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openldap-clients.x86_64 0:2.4.23-32.el6_4.1 will be installed
--> Processing Dependency: openldap = 2.4.23-32.el6_4.1 for package: openldap-clients-2.4.23-32.el6_4.1.x86_64
--> Running transaction check
---> Package openldap.i686 0:2.4.23-32.el6_4.1 will be installed
--> Processing Dependency: libssl3.so(NSS_3.7.4) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libssl3.so(NSS_3.4) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libssl3.so(NSS_3.2) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libssl3.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libsmime3.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libsasl2.so.2 for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libresolv.so.2(GLIBC_2.2) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libresolv.so.2 for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libplds4.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libplc4.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnssutil3.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.9.3) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.9.2) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.8) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.6) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.4) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.3) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.2) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.12.9) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.12.5) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.12.1) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.12) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.11.1) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.11) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so(NSS_3.10) for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnss3.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libnspr4.so for package: openldap-2.4.23-32.el6_4.1.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: openldap-2.4.23-32.el6_4.1.i686
--> Running transaction check
---> Package cyrus-sasl-lib.i686 0:2.1.23-13.el6_3.1 will be installed
--> Processing Dependency: libdb-4.7.so for package: cyrus-sasl-lib-2.1.23-13.el6_3.1.i686
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6.i686
---> Package nspr.i686 0:4.10.0-1.el6 will be installed
---> Package nss.i686 0:3.15.1-15.el6 will be installed
--> Processing Dependency: nss-softokn(x86-32) >= 3.14.3 for package: nss-3.15.1-15.el6.i686
--> Processing Dependency: libz.so.1 for package: nss-3.15.1-15.el6.i686
--> Processing Dependency: libsoftokn3.so for package: nss-3.15.1-15.el6.i686
---> Package nss-util.i686 0:3.15.1-3.el6 will be installed
--> Running transaction check
---> Package db4.i686 0:4.7.25-18.el6_4 will be installed
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
---> Package nss-softokn.i686 0:3.14.3-9.el6 will be installed
--> Processing Dependency: libsqlite3.so.0 for package: nss-softokn-3.14.3-9.el6.i686
---> Package nss-softokn-freebl.i686 0:3.14.3-9.el6 will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
---> Package sqlite.i686 0:3.6.20-1.el6 will be installed
--> Processing Dependency: libreadline.so.6 for package: sqlite-3.6.20-1.el6.i686
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
---> Package readline.i686 0:6.0-4.el6 will be installed
--> Processing Dependency: libtinfo.so.5 for package: readline-6.0-4.el6.i686
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
---> Package ncurses-libs.i686 0:5.7-3.20090208.el6 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.132.el6.i686 (cdrom)
           Requires: glibc-common = 2.12-1.132.el6
           Installed: glibc-common-2.12-1.132.el6_5.2.x86_64 (@updates)
               glibc-common = 2.12-1.132.el6_5.2
           Available: glibc-common-2.12-1.132.el6.x86_64 (cdrom)
               glibc-common = 2.12-1.132.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It would seem that I do not have the right package for my version installed already:

[root@test1 yum.repos.d]# rpm -qa | grep glibc
glibc-common-2.12-1.132.el6_5.2.x86_64
glibc-2.12-1.132.el6_5.2.x86_64

Obviously if I try and remove glibc and reinstall from the CD-ROM which would provide a newer version I receive a whole lot of errors since glibc cannot exactly be removed...

[root@test1 yum.repos.d]# yum install glibc*
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Package matching glibc-2.12-1.132.el6.x86_64 already installed. Checking for update.
Package matching glibc-common-2.12-1.132.el6.x86_64 already installed. Checking for update.
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc = 2.12-1.132.el6 for package: glibc-devel-2.12-1.132.el6.x86_64
---> Package glibc-headers.x86_64 0:2.12-1.132.el6 will be installed
---> Package glibc-utils.x86_64 0:2.12-1.132.el6 will be installed
--> Processing Dependency: libgd.so.2()(64bit) for package: glibc-utils-2.12-1.132.el6.x86_64
--> Running transaction check
---> Package gd.x86_64 0:2.0.35-11.el6 will be installed
--> Processing Dependency: libXpm.so.4()(64bit) for package: gd-2.0.35-11.el6.x86_64
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6.i686
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.132.el6 for package: glibc-2.12-1.132.el6.i686
---> Package libXpm.x86_64 0:3.5.10-2.el6 will be installed
---> Package nss-softokn-freebl.i686 0:3.14.3-9.el6 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.132.el6.i686 (cdrom)
           Requires: glibc-common = 2.12-1.132.el6
           Installed: glibc-common-2.12-1.132.el6_5.2.x86_64 (@updates)
               glibc-common = 2.12-1.132.el6_5.2
           Available: glibc-common-2.12-1.132.el6.x86_64 (cdrom)
               glibc-common = 2.12-1.132.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

What can I do to remove this _5.2 version of glibc and replace it with the newer version available on the disc?

  • It looks like there are some architecture problem, as the openldap-clients.x86_64 (note: 64 bit) correctly require the "openldap" package that is resolved to "openldap.i686" (note: 32 bit). This, in the end, last to the request to install the 32 bit release of the glibc (glibc-2.12-1.132.el6.i686) while you've installed the 64 bit (glibc-common-2.12-1.132.el6_5.2.x86_64). Please, tell us some details about your architecture and if you're (deliberately/not) using 32bit packages in a 64bit system. – Damiano Verzulli Aug 13 '15 at 20:51
  • @DamianoVerzulli my attempt is to use a 64bit architecture (x86_64). I am not deliberately using or not using 32bit packages. I typically just install packages and the system ends up installing what it is I need. For instance if I want to install sssd I did yum install sssd* so that I would obtain all the packages. – user2104891 Aug 13 '15 at 23:16
  • If you try to install the openldap package, what version yum will choose? 32 or 64bit? In the first case, what happens if you explicitely ask for the 64bit version (yum install openldap.x86_64)? The idea is to manually solve dependencies forcing proper architecture. – Damiano Verzulli Aug 14 '15 at 6:14
  • @DamianoVerzulli If I try and install the openldap, allowing yum to decide the architecture I receive the message that openldap is already installed which is expected but since I also want openldap-clients Package openldap-clients.x86_64 0:2.4.23-32.el6_4.1. tries to install the 64bit package. As in the description above, it wants to install both 32bit and 64bit packages...which then at the end glibc is all kinds of screwed up. – user2104891 Aug 14 '15 at 12:13
  • So, currently, the 32bit version of the "openldap" package is installare in your system? You can check with the output of "rpm -qi openldap" – Damiano Verzulli Aug 14 '15 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.