17

Today I ran across a problem and I'm not sure if it's a wrong configuration of my hosting provider, because I haven't changed anything about the file system.

df -h says:

df -h
Filesystem Size Used Avail Use%  Mounted on
/dev/simfs 50G  2.4G  0    100%  /

It says it's 100% used, but only 2.4G of 50 are really in use. I've also tried to delete some logfiles which were big, but it didn't help.

I've also checked with "du -sh *" if there's anything big, but couldn't find anything large.

Anyone has an idea?

//edit: There are enough INodes free.

df -hi
Filesystem     Inodes IUsed IFree IUse% Mounted on
/dev/simfs        25M  137K   25M    1% /

//edit: Complete output:

df -T
Filesystem     Type     1K-blocks    Used Available Use% Mounted on
/dev/simfs     simfs     52428800 2127284         0 100% /
none           devtmpfs    262144       4    262140   1% /dev
none           tmpfs        52432      56     52376   1% /run
none           tmpfs         5120       0      5120   0% /run/lock
overflow       tmpfs         1024       0      1024   0% /tmp
none           tmpfs       209700       0    209700   0% /run/shm
none           tmpfs       102400       0    102400   0% /run/user

//edit: Permissions:

ls -la /dev/simfs
brw------- 1 root root 144, 149 Aug 14 00:01 /dev/simfs
  • There are probably some issues with disk space/quotas on machine hosting your VM, you should contact your hosting provider. – Dusan Bajic Aug 14 '15 at 13:45
  • That's also my current thought, I've already contacted them (waiting for an answer). – Zazama Aug 14 '15 at 13:52
  • 1
    have you also looked for orphaned file descriptors? i.e. lsof -n | grep -i delet – Aaron Aug 14 '15 at 17:03
30

You're using an OpenVZ-based VPS, and on this VPS your root filesystem isn't really a filesystem, but a directory on the host. That directory on the host has run out of disk space.

This is a strong sign that your provider has significantly overcommitted resources and isn't monitoring them well, or at all. The replacement for simfs, known as ploop, is more difficult to overcommit, has a stronger guarantee of disk space, and performs better.

I would strongly advise you to find another provider as soon as possible. This is very unlikely to be the last problem you will have with your current one. (And, of course, one not based on OpenVZ.)

  • 2
    Thanks for your explaination, sounds reasonable. I have my VPS for half a year and didn't have any problems until last night. It's also only a small one with 512mb ram, which doesn't need much power. I'll wait for their explaination and then I'll decide what to do. – Zazama Aug 14 '15 at 16:10
  • 2
    Turned out you were right, it was a problem on their side. Obviously, they didn't acknowledge that they overcommitted their host system :P – Zazama Aug 14 '15 at 19:49
  • @Zazama So... What did you decide to do? – irrational John Aug 15 '15 at 13:37
  • @irrationalJohn Well, they fixed it within 2 hours after I got a response from them and they gave me 9 days for free, so I've decided to stay there. I don't host important projects on this server, so the downtime wasn't a big deal. But for my future, I've learned that it's better to spend more money for better quality and support if it's important (I'm talking about downtime because writing to database didn't work anymore which forced me to take the site down). – Zazama Aug 16 '15 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.