1

I'm running PHP on Nginx using fpm. The reported memory_limit is 128M and i cannot change it for the life of me.

PHPInfo:

  • Server API: FPM/FastCGI
  • Config file: /etc/php5/fpm/php.ini
  • Memory limit: 128M

The memory_limit in /etc/php5/fpm/php.ini is 256M

If i run grep -Ri "memory_limit" /etc it returns:

/etc/php5/fpm/pool.d/www.conf.dpkg-dist:;php_admin_value[memory_limit] = 32M                    │Max: 921.53 kBit/s                              Max: 11.70 MBit/s
/etc/php5/fpm/pool.d/www.conf:;php_admin_value[memory_limit] = 32M                              │Ttl: 233.43 kByte                               Ttl: 2.14 MByte
/etc/php5/fpm/php.ini:memory_limit = 256M                                                       │
/etc/php5/cli/php.ini:memory_limit = -1

I have stopped nginx and php-fpm, done sudo killall php-fpm and restarted nginx and php-fpm. Memory_limit is still 128M.

Phpinfo

Please send help.

  • 2
    Reboot fixed it. Shouldn't be necessary though? – Maciej Swic Aug 15 '15 at 15:19
  • Wow ... I tried EVERYTHING and rebooting finally worked for me too. – beingalex Nov 18 '15 at 11:36
  • I had the same issue. A reboot wasn't necessary; simple apachectl graceful was enough. Thanks for posting this question, though; it helped me realise what to try. – qu1j0t3 Jan 15 '17 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.