3

I have 3 x Mikrotik RB951Ui-2HnD router board (RB) running 6.31 with wlan1 bridged with ethernet 2.

STP is disabled on the RB bridge (protocol mode set to None).

I have a HP ProCurve 2520-24-PoE switch (flat, no config) connecting to the RB951's (I have tried with the ProCurve having Spanning Tree both enabled and disabled, plus with Mikrotik bridge set to RSTP and also None, makes no difference).

Using a number of DELL Windows 8.1 clients i connect to the access point and Windows spins connecting saying it is taking longer than usual. Clients connecting via Ethernet cable get an IP address instantly.

If i set my WiFi NIC on the Windows machine to a correct IP statically I am not able to ping the server, or the router, until about 60 to 90 seconds after connecting... so seems my packets are being blocked. During this time of no connectivity to the wider network, I am able to ping and connect to the RB.

If i log in to the RB on winbox from the laptop whilst i am unable to connect, from the terminal on RB i am able to ping the server and gateway.

Other times when I connect it is instantly connected, no pattern for it.

This is so simple yet has me stumped - any ideas what on earth is going on and how to diagnose?

Is there a compatibility problem or some kind of spanning tree in effect?

Config below from Mikrotik (the HP ProCurve is default blank):

/interface bridge
add admin-mac=4C:5E:0C:03:9B:3F auto-mac=no name=bridge-local protocol-mode=\
    none
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
    ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
    ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=\
    ether5-slave-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=\
    "united arab emirates" disabled=no distance=indoors l2mtu=1600 mode=\
    ap-bridge ssid="Sales" wireless-protocol=802.11
/ip neighbor discovery
set ether1-gateway discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=change!me! \
    wpa2-pre-shared-key=change!me
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.1.201/24 comment="default configuration" interface=\
    ether2-master-local network=192.168.1.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=\
    no interface=ether1-gateway
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip dns static
add address=192.168.1.201 name=router
/ip route
add distance=1 gateway=192.168.1.254
/system clock
set time-zone-autodetect=no
/system identity
set name=Mikrotik
/system leds
set 5 interface=wlan1
/system package update
set channel=current
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local
/tool romon port
add
  • 1
    Please post your configuration. /export – Cha0s Aug 17 '15 at 11:52
  • I am not sure I see any problems with your config. I do see that you have assigned 192.168.1.201/24 on interface ether2-master-local instead of bridge-local. Try changing that. Also I cannot see your dhcp-server configuration. Finally from which interface is 4C:5E:0C:03:9B:3F that you have assigned on the bridge? – Cha0s Aug 19 '15 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.