1

My Amazon web instance (EC2) is suddenly unresponsive. I can't ssh in, and I can't properly load the website via my web browser; only basic text and broken image links appear. The only change I know of is that I recently updated my public IP for the website. I'm quite new to AWS; any idea why my instance might be unresponsive? Is it possible to check its "health" somewhere? (I can see CloudWatch metrics from the web console, but it is not providing any useful information.)

Update: This appears to be problem others encounter as well, but I haven't found any resolution as of yet.

  • did you set your dns name within your web server (apache/nginx or whatever)? are you using an ssl certificate? you can have some information through cloudwatch metrics, or get the machine system log by clicking right on your "instance > instance settings > get system log" from the UI. However, if you want advanced monitoring, you will have to use an external tool (there are a lot of tools available, such as nagios, zabbix, newrelic, dynatrace etc). you can also install the aws cloudwatch agent on your machine to get your own logs and metrics – Tom Aug 18 '15 at 15:52
  • I didn't set the DNS name, no. I am not using an SSL certificate. – Dylan Knowles Aug 18 '15 at 15:58
  • mmh... and what instance type are you using, with what running on it? – Tom Aug 18 '15 at 16:07
  • ubuntu-trusty-14.04-amd64-server-20150325 , with an Elgg website running. – Dylan Knowles Aug 18 '15 at 19:18
  • 1
    I have had a micro instance in the past, with mysql + apache + solr (but very small usage of solr) running. The vm was crashing from time to time. I reduced the number of child processes launched by apache and it worked properly then. As a test, you can easily change your instance size by right-clicking the instance > instance settings > change instance type (your instance has to be stopped to do so). You can try with a bigger one, test if it works and eventually come back to micro instance if you wish – Tom Aug 18 '15 at 21:20
0

After I regained the ability to ssh into my web instance, which occurred spontaneously after some time, I discovered that my Elgg installation was the problem. Specifically, it was using the old IP address of my web instance; I simply needed to provide the new one. A very specific problem, I know, but hopefully it helps someone else!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.