0

I am using Redmine version 2.5.2 Stable.

After a server crash, we rebooted our server and found that redmine is not starting.

When I start rails using command rails s, I get the following error:

/usr/lib/ruby/site_ruby/1.8/rubygems.rb:233:in `activate': can't activate rack (~> 1.4.5, runtime) for ["actionpack-3.2.18", "railties-3.2.18"], already activated rack-1.6.0.beta for ["rack-ssl-1.3.4", "railties-3.2.18"] (Gem::LoadError)
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:249:in `activate'
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:248:in `each'
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:248:in `activate'
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:249:in `activate'
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:248:in `each'
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:248:in `activate'
            from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:1082:in `gem'
            from /usr/local/rvm/gems/ruby-1.9.3-p547/bin/rails:22
            from /usr/local/rvm/gems/ruby-1.9.3-p547/bin/ruby_executable_hooks:15

Please find my gem list

*** LOCAL GEMS ***

actionmailer (3.2.18, 3.2.17)
actionpack (3.2.18, 3.2.17)
activemodel (3.2.18, 3.2.17)
activerecord (3.2.18, 3.2.17)
activeresource (3.2.18, 3.2.17)
activesupport (3.2.18, 3.2.17)
acts-as-taggable-on (2.3.3)
arel (3.0.3)
awesome_nested_set (2.1.6)
builder (3.0.4, 3.0.0)
bundler (1.9.2, 1.7.3)
capybara (2.1.0)
childprocess (0.5.3)
coderay (1.1.0, 1.0.9)
coffee-rails (3.2.2)
coffee-script (2.2.0)
coffee-script-source (1.7.0)
commonjs (0.2.7)
daemon_controller (1.2.0)
daemons (1.1.9)
delayed_job (4.0.6)
delayed_job_active_record (4.0.3)
diff-lcs (1.2.5)
erubis (2.7.0)
eventmachine (1.0.3)
execjs (2.5.2, 2.0.2)
faraday (0.8.8)
fastercsv (1.5.5)
ffi (1.9.3)
git (1.2.9.1)
hashie (2.0.5)
hike (1.2.3)
httpauth (0.2.0)
i18n (0.7.0, 0.6.11, 0.6.9)
journey (1.0.4)
jquery-rails (3.0.4, 2.0.3)
jquery-ui-rails (5.0.3, 5.0.2)
json (1.8.2, 1.8.1)
jwt (0.1.8)
less (2.3.3)
less-rails (2.3.3)
less-rails-bootstrap (2.3.3)
libv8 (3.11.8.17 x86_64-linux, 3.11.8.13 x86_64-linux)
liquid (2.4.1)
mail (2.5.4)
metaclass (0.0.4)
method_source (0.8.1)
mime-types (1.25.1)
mini_portile (0.6.0)
mocha (1.1.0)
money (5.0.0)
multi_json (1.11.0, 1.10.1, 1.10.0)
multipart-post (1.2.0)
mysql2 (0.3.18, 0.3.16)
net-ldap (0.3.1)
node (0.0.2)
nokogiri (1.6.3.1)
oauth2 (0.8.1)
omniauth (1.1.4)
omniauth-oauth2 (1.1.1)
omniauth-shopify-oauth2 (1.1.2)
passenger (5.0.6, 4.0.50)
pg (0.16.0)
polyglot (0.3.5, 0.3.4)
pry (0.9.12.2)
pry-rails (0.3.1)
quiet_assets (1.0.2)
rack (1.6.0.beta, 1.4.5)
rack-cache (1.2)
rack-openid (1.4.2)
rack-ssl (1.3.4)
rack-test (0.6.3, 0.6.2)
rails (3.2.18, 3.2.17)
railties (3.2.18, 3.2.17)
rake (10.4.2, 10.3.2, 10.3.1)
rdoc (3.12.2)
redcarpet (2.3.0)
RedCloth (3.0.4)
ref (1.0.5, 1.0.2)
render_parent (0.0.5)
rmagick (2.14.0, 2.13.3)
rspec (3.2.0)
rspec-core (3.2.3)
rspec-expectations (3.2.1)
rspec-mocks (3.2.1)
rspec-support (3.2.2)
ruby-ole (1.2.11.8)
ruby-openid (2.3.0)
rubyzip (1.1.6)
sass (3.3.7)
sass-rails (3.2.6)
selenium-webdriver (2.43.0)
shopify_api (3.0.3)
shopify_app (4.2.3)
shoulda (3.3.2)
shoulda-context (1.0.2)
shoulda-matchers (1.4.1)
slim (3.0.3)
slop (3.4.5)
spreadsheet (0.6.9)
sprockets (2.2.3, 2.2.2)
sqlite3 (1.3.7)
state_machine (1.2.0)
temple (0.7.5)
therubyracer (0.11.4)
thor (0.19.1)
tilt (1.4.1)
treetop (1.4.15)
tzinfo (0.3.43, 0.3.41, 0.3.39)
vcard (0.2.12)
webrat (0.7.3)
websocket (1.2.1)
will_paginate (3.0.7)
xpath (2.0.0)
yard (0.8.7.4)

closed as off-topic by user9517, Ward, womble, Jenny D, masegaloeh Aug 22 '15 at 3:41

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1

Some of your packages need rack (~> 1.4.5, runtime) so remove the beta version that you've installed and install the stable version 1.4.5 then you can start your rails project.

Not the answer you're looking for? Browse other questions tagged or ask your own question.