1

Source: Server 2012 R2 Destination: Server 2012

This is the command I use to export:

C:\Program Files\IIS\Microsoft Web Deploy V3>msdeploy -verb:sync  -source:apphos
tconfig="mywebsite" -dest:package=c:\test.zip,encryptPassword=password -skip:Directory= -skip:File=

The following is the error I get in IIS when attempting an import:

Microsoft.Web.Deployment.DeploymentException: Child object 'customFields' cannot be added to object 'logFile'. The 'logFile' provider may not support this deployment. at Microsoft.Web.Deployment.DeploymentObject.AddChild(DeploymentObject source, Int32 position, DeploymentSyncContext syncContext) at Microsoft.Web.Deployment.DeploymentSyncContext.HandleAddChild(DeploymentObject destParent, DeploymentObject sourceObject, Int32 position) at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source) at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source) at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenNoOrder(DeploymentObject dest, DeploymentObject source) at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source) at Microsoft.Web.Deployment.DeploymentSyncContext.ProcessSync(DeploymentObject destinationObject, DeploymentObject sourceObject) at Microsoft.Web.Deployment.DeploymentObject.SyncToInternal(DeploymentObject destObject, DeploymentSyncOptions syncOptions, PayloadTable payloadTable, ContentRootTable contentRootTable, Nullable`1 syncPassId, String syncSessionId) at Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentProviderOptions providerOptions, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions) at Microsoft.Web.Deployment.UI.InstallProgressWizardPage.OnWorkerDoWork(Object sender, DoWorkEventArgs e) at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

1 Answer 1

2

I should have seen this one miles away...

I unzipped the backup file and edited the archive.xml file removing the line with the dredded "customFields". Problem solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .