16

Since upgrading a machine from Windows 8.1 Professional to Windows 10 Professional (workgroup, no domain membership), I've been experiencing a rather strange issue that I can't figure out. The initial remote desktop connection is very slow to connect (on the order of two minutes). However, after the initial connection is made, I can close the connection and reconnect almost immediately. Also, after the initial connection is made, I can close the connection and reconnect using another machine entirely without experiencing the long delay. I've tested the remote desktop clients on Windows 7, 8.1, and 10, and all experience the same slow initial connection to the Windows 10 machine, so I believe the problem lies on the server side.

Things I've tried so far:

  • Turning off "Automatic Root Certificates Update" via local computer policy:
    (Computer Configuration -> Administrative Templates -> System -> Internet Communication Settings -> Turn Off Automatic Root Certificates Update).
    Suggestion from technet, by user "dsoic" midway down the page. It was also suggested to disable CredSSP, but I don't think disabling Network Level Authentication is a good choice.
  • Forcing TCP as the only RDP transport protocol
    (Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Connections -> Select RDP transport protocols),
    suggested by user "Jayson Allen" on spiceworks. I also checked the FIPS setting, but on Windows 10 it appears to be disabled by default.

Neither has improved the situation. Does anyone have any advice on how to proceed?

EDIT: The Threshold 2 update has corrected this issue on my system.

  • Try and disable "Smart Card Device Enumeration Service" and see if it improves. I had a similar issue and this resolved it. – Noah Sparks Aug 24 '15 at 13:44
  • Thank you for the suggestion! I tried disabling the "Smart Card Device Enumeration Service", and the first login after reboot was fine. However, reconnecting to a session that has been disconnected for a while still causes a long delay. I'm not sure what would be different about reconnecting to a disconnected session vs. initial logon that would be a source of delay. – JMC Aug 25 '15 at 13:46
  • I'm having the same issue across the board with Windows 10 in an out of domain environment and I haven't figured it out. What a pain. Seriously microsoft, you didn't test this? – Peter M Aug 31 '15 at 18:29
  • As a test, I disabled the option of requiring Network Level Authentication, but the same issue occurred. Still not sure what the root cause of this problem is. – JMC Sep 3 '15 at 14:06
  • 1
    This may help you: serverfault.com/questions/731722/… – Dave Oct 26 '15 at 15:15
2

It's a result of aggressive auto-tuning of the connection which causes the delay on startup. Running the following should resolve your issue.

netsh interface tcp set global autotuninglevel=highlyrestricted

More details: Remote Desktop slow problem solved

  • Alas, this doesn't seem to work. I've tried this setting on both my Windows 8.1 client and the Windows 10 session host. Once I've endured the delay and connected to Windows 10, reconnection is much quicker with or without this setting. However when I shut down the client host (as I do daily) and reconnect some time later (usually overnight), the problem reappears. – Robert Mooney Oct 30 '15 at 16:26
  • This did not work for me either (Windows 10 Professional). – JMC Nov 2 '15 at 1:09
1

Well, after being unable to determine the root cause of the issue, I tried a fresh install of Windows 10 Professional. The reinstall has corrected the slow initial connection issue, so all that I can say is that this problem was most likely some sort of corruption or setting issue caused by the upgrade process.

Edit: I spoke too soon. The issue started again approximately one week after reinstalling Windows. I'm still searching for the root cause.

  • Have you been able to speak to Microsoft yet in anyway about the issue or posted to their forums? – Jason Sep 20 '15 at 15:13
  • I have not spoken to Microsoft about this issue. Which forum would you recommend? – JMC Sep 22 '15 at 17:00
  • I think they are answers.microsoft.com/en-us – Jason Sep 22 '15 at 22:53
1

I have solved this problem by changing the Mircosoft account to local account .

Edit: RDP initial connection is sometimes still slow , but better than using remote Microsoft account .

  • I'm only using a local account, so this does not work in my case. – JMC Sep 22 '15 at 16:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.