3

Somehow I can not get glusterfs running again on ubuntu 14.04. I used to have it up and running a few days ago, including a configured volume. Then I removed the start script from autostart.

Now I get "failed" on starting the daemon. Then I purged the package and tried to reinstall. This is where I get following output:

Setting up glusterfs-server (3.7.3-ubuntu1~trusty1) ...
 * Starting glusterd service glusterd                                                                                                                                    [fail] 
invoke-rc.d: initscript glusterfs-server, action "start" failed.
dpkg: error processing package glusterfs-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for ureadahead (0.100.0-16) ...
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
                                                                                                  Errors were encountered while processing:
 glusterfs-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

This are the entries of the logfile:

[2015-08-23 19:10:33.979995] I [MSGID: 106478] [glusterd.c:1346:init] 0-management: Maximum allowed open file descriptors set to 65536
[2015-08-23 19:10:33.980021] I [MSGID: 106479] [glusterd.c:1395:init] 0-management: Using /var/lib/glusterd as working directory
[2015-08-23 19:10:33.982396] W [MSGID: 103071] [rdma.c:4590:__gf_rdma_ctx_create] 0-rpc-transport/rdma: rdma_cm event channel creation failed [No such device]
[2015-08-23 19:10:33.982416] W [MSGID: 103055] [rdma.c:4896:init] 0-rdma.management: Failed to initialize IB Device
[2015-08-23 19:10:33.982427] W [rpc-transport.c:359:rpc_transport_load] 0-rpc-transport: 'rdma' initialization failed
[2015-08-23 19:10:33.982457] W [rpcsvc.c:1597:rpcsvc_transport_create] 0-rpc-service: cannot create listener, initing the transport failed
[2015-08-23 19:10:33.982464] E [MSGID: 106243] [glusterd.c:1619:init] 0-management: creation of 1 listeners failed, continuing with succeeded transport
[2015-08-23 19:10:35.272379] I [MSGID: 106513] [glusterd-store.c:2036:glusterd_restore_op_version] 0-glusterd: retrieved op-version: 30703
[2015-08-23 19:10:35.427785] I [MSGID: 106498] [glusterd-handler.c:3570:glusterd_friend_add_from_peerinfo] 0-management: connect returned 0
[2015-08-23 19:10:35.427848] I [rpc-clnt.c:972:rpc_clnt_connection_init] 0-management: setting frame-timeout to 600
[2015-08-23 19:10:35.508741] E [MSGID: 101075] [common-utils.c:314:gf_resolve_ip6] 0-resolver: getaddrinfo failed (Name or service not known)
[2015-08-23 19:10:35.508788] E [name.c:247:af_inet_client_get_remote_sockaddr] 0-management: DNS resolution failed on host gluster2
[2015-08-23 19:10:35.508957] I [MSGID: 106004] [glusterd-handler.c:5051:__glusterd_peer_rpc_notify] 0-management: Peer <gluster2> (<6184be8c-f171-455f-a94f-dcf3ac6e1be1>), in state <Peer in Cluster>, has disconnected from glusterd.
[2015-08-23 19:10:35.508993] E [MSGID: 106155] [glusterd-utils.c:199:glusterd_unlock] 0-management: Cluster lock not held!
[2015-08-23 19:10:35.514145] E [MSGID: 106408] [glusterd-peer-utils.c:120:glusterd_peerinfo_find_by_hostname] 0-management: error in getaddrinfo: Name or service not known
 [Unknown error -2]
[2015-08-23 19:10:35.519159] E [MSGID: 101075] [common-utils.c:3139:gf_is_local_addr] 0-management: error in getaddrinfo: Name or service not known

[2015-08-23 19:10:35.519192] E [MSGID: 106187] [glusterd-store.c:4243:glusterd_resolve_all_bricks] 0-glusterd: resolve brick failed in restore
[2015-08-23 19:10:35.519271] E [MSGID: 101019] [xlator.c:428:xlator_init] 0-management: Initialization of volume 'management' failed, review your volfile again
[2015-08-23 19:10:35.519280] E [graph.c:322:glusterfs_graph_init] 0-management: initializing translator failed
[2015-08-23 19:10:35.519285] E [graph.c:661:glusterfs_graph_activate] 0-graph: init failed
[2015-08-23 19:10:35.519655] W [glusterfsd.c:1219:cleanup_and_exit] (-->/usr/sbin/glusterd(glusterfs_volumes_init+0xcd) [0x7f8a6c1f507d] -->/usr/sbin/glusterd(glusterfs_process_volfp+0x126) [0x7f8a6c1f4f56] -->/usr/sbin/glusterd(cleanup_and_exit+0x69) [0x7f8a6c1f4589] ) 0-: received signum (0), shutting down

I believe I need to reset the configuration as the paths are now different. How do I do this?

10

just found the solution. For reference:

After removing /var/lib/glusterd I was able to start glusterd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.