1

I have a Dell T7600 workstation with Perc H200 controller card (did not come with the box previously, was installed after since the standard onboard card only does 3Gb/s connections). Anyway, the machine has been running Linux for the last few months and has had no issues, but I need to move to Server 2012 R2, and I cant get it to see the drives on the controller.

There are 8 disks in the controller: 2 Samsung 850 Pros, which I have setup in a RAID array, 4 2Tb hard drives, a 1Tb disk and a 128Gb SSD. They are left as is, and are not setup in RAID.

I have loaded the H200 drivers using an external USB key, which it does see the "correct" drivers, but still wont show any disks. I have made sure the RAID array is set to boot in the controller, and the BIOS can "see" the drives and array. I even tried removing the array fully and tried installing that way (no arrays, just disks) but no dice. Windows Installer still cant see drives.

I know this is going to be something simple... I just cant seem to find the answer myself.

[Update] Tried some more stuff last night, still no luck. Things i tried:

  • delete raid array and re-created
  • tried setting the boot option to UEFI
  • made sure the RAID array is set to boot from (it is)
  • made sure BIOS can actually see the RAID array (sees all disks, including the RAID disk, and that disk is set to first priority, after USB and CD)

Trying to build this with an ISO i got from microsoft.com and the latest Dell H200 driver... When the installer gets to the select disk screen, nothing is shown, i select find driver, and point at the usb key with the driver, it finds H200, but still wont find any disks...

1

So, want a laugh? Today, I burned a new iso with a retail copy of windows server 2012 r2, since previously I was using a trial copy. I also had a new key with extra drivers, just in case... Well, booted the disk, entered my key and.... It worked... Found all drives! No driver required or nothing! /facepalm... Media problem in the end... Sorted now though...

0

Solved this problem myself with a T110 II and a H200A aka 2008-IR based on LSI chip 9211-BI and there are two solutions. Firmware update the card using version 05 of sas2flash.exe with the new firmware file for 9211-from a DOS boot disk and make sure to document the chip's unique hardware address before erasing and then flashing the chip. OR, I found that by simply entering the RAID configuration utility with CTRL-R during boot and choosing adapter properties then change the "Boot Support" option from "Enabled BIOS & OS" to "BIOS only" and exit saving changes and reboot will fix the issue as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.