As a volume containing a LUN filled up to 100% on a NetApp FAS running ONTAP 7.x, the LUN went offline automatically, stopping the VMs.

Now we need to delete snapshots or files on the volume to bring in online again. But I can't figure out how to do that. I found the possibility to delete old snapshots and this is what I have done so far. That was enough to get some free space and bring the LUN back online again.

But is it possible to delete files as well and if so, how to do that?

  • Are there any snapshots still left on the volume?
    – MadHatter
    Aug 25 '15 at 11:42
  • yes, there were snapshots and I solved my problem by deleting the snapshots which has freed enough space to bring the volume und the lun up again and administer the space from the vmware cluster again.
    – mgabriel
    Aug 26 '15 at 22:34
  • That is good, because as long as there are snapshots, deleting files will free up no space at all. Glad you're back and working.
    – MadHatter
    Aug 27 '15 at 5:49

Deleting files inside the server that uses the LUN will not necessarily free up space. VMWare leaves data from its deleted files all over the disk, dereferencing deleted files without actually removing or overwriting their data. If you're using a supported combination of VMWare and Netapp, you can use a special VAAI command to unreference scsi sectors that are no longer part of the file system.

Aside from that, LUNs can not be shrunk, so your choices are to use VM level tools to copy the data to a new VM on a new LUN and delete the old one after the copy, or to grow the volume.


Although I didn't find a solution for deleting files directly by using the CLI, I discovered some old snapshots. I was able to delete those old snapshots by using the CLI and that gave me some free space again on the LUN.

How to delete snapshots by using the CLI I could find here: http://www.sysadmintutorials.com/tutorials/netapp/netapp-data-ontap-7-mode/netapp-data-ontap-cli/

Afterwards, I could bring the volume and the LUN back online again and removed the rest of the snaps by using the VMware Admin Interface. That solved the problem.

It was caused by a specific VM that had hundreds of snapshots, created by Veeam, but still existing. After deleting them, I had plenty of space again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.