0

I had a working gluster installation runnning on ubuntu 14.04. Now I have reconnected the sata ports and the gluster brick is now mounted from the other port. It is available:

/dev/sda1                    236M   38M  186M  17% /boot
/dev/sdc1                     20G  7.2G   12G  39% /data/gluster
/dev/sdb1                    7.8G  2.9G  4.5G  39% /data/mysql

Unfortunatelly I can not mount it anymore:

~sudo mount gs1:volume1 /data/nfs

nothing happens, cursor stays in blank line. I have to cancel with ctrl c or wait until I get a timout:

node1:~sudo mount gs1:volume1 /data/nfs
mount.nfs: Connection timed out

volume info

Volume Name: volume1
Type: Replicate
Volume ID: 92d9adb8-756b-4138-87a8-23237d21688f
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: gs1:/data/gluster/brick
Brick2: gs2:/data/gluster/brick

There is nothing in the logs. The IP Adress of the gluster servers are in /etc/hosts and I can ping them.

How could I fix this error?

0

I found the problem. Gluster-Server on node 2 was not running and the entry for mounting the volume in /etc/fstab contained the startup option to failover to gs2. Somehow this prevents gs1 from mounting the drive. once gs2 is live, the share can be mounted from gs1.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.