3

Dreamweaver CS4 uses the subversion 1.4.5 client libraries, and we are wanting to change our source control from some weird proprietary one to subversion. The latest subversion is 1.6.x, will we have any issues doing simple checkin/checkouts and the occassional fork?

Servers are OpenSUSE 10, clients are Dreamweaver CS4 on windows XP

5

It should work OK according to the compatibility charts at http://subversion.tigris.org/svn_1.5_releasenotes.html and http://subversion.tigris.org/svn_1.6_releasenotes.html. You shouldn't have problems with basic operations and branching.

  • great, we can not have some newer features until adobe updates their client. Thank you. – MrChrister May 12 '09 at 3:02
2

All subversion clients work with different servers - the client sends its version number and basically only gets the capabilities that both system provide. Its very rare to have something that is totally incompatible.

That said, there's no reason why you shouldn't have 1.6 SVN client as well, you just need to step outside the IDE for a little. Get yourself TortoiseSVN, it'll hook itself into explorer and when things change, it'll put a little orange (or red) marker on the icon. You can work with SVN through that, using explorer. Its really nice and very easy to use.

The only thing you'll notice is if you try to use the IDE integration as well, Dreamweaver will complain that the working copy is not the right one and will not allow you to do anything with the SVN integration, so don't bother turning it on - use tortoise by itself.

The advantages of later SVN releases (better merge tracking and sparse directories, plus the few bugfixes and performance improvements) really make me recommend using Tortoise over Dreamweaver's 1.4.5 version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.