1

How can I disable last message repeated X times compression in syslog-ng? I use certain log messages as triggers and this effectively hides them. Defining suppress(0) doesn't do what I want.

1
  • 2
    Hi, suppress(0) should disable this feature, but that is also the default. Check if it is not enabled in another part of your config. Aug 28 '15 at 17:29
1

When I got stuck with this same problem rsyslog was the easiest solution, despite syslog-ng is easy to understand and configure rsyslog has a bit more potential for my point of view.

By the way, if the loging frequency for such event is soy high this might impact on your storage resources and also network/CPU performance. It you an add and extract from your syslog-ng config and output may help to get a proper answer.

This may help you:

Is there a way to remove "Last message repeated x times" from logs?

0

The global option, suppress() turns the functionality on and off.

https://www.syslog-ng.com/technical-documents/doc/syslog-ng-open-source-edition/3.16/administration-guide/suppress

1
  • OP mentioned this doesn’t work for him ....
    – Sven
    Jul 8 '18 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.