1

Trying to create an AMI Instance Store within a xen based guest (VM: CentOS 6.6, 32 bit, PV).

'ec2-bundle-vol' only accepts /dev/xvda1 as a valid block device. If device entries are modified in /etc/fstab and /boot/grub/grub.conf before (/dev/sda1 or /dev/xvde1) the tool escapes with error-message 'Not a block device: (FatalError'.

Also tried 'bundle' options as: --block-device-mapping ami=sda,root=/dev/sda1,swap=sda2

or using dedicated config files as: --fstab /tmp/fstab \ --grub-config /tmp/grub.conf

without success. Found also an 'unknown' kernel-boot-option 'xen_blkfront.sda_is_xvda=1' but this fails completely at AWS boot.

If going on uploading (ec2-bundle-upload') with /dev/xvda finally the registered AMI Image does not boot.

AWS System Log:

blkfront: xvde1: barriers disabled Changing capacity of (202, 65) to 13312000 sectors xvde1: detected capacity change from 0 to 6815744000 blkfront: xvde2: barriers disabled blkfront: xvde3: barriers disabled Changing capacity of (202, 66) to 312705024 sectors xvde2: detected capacity change from 0 to 160104972288 Changing capacity of (202, 67) to 1835008 sectors xvde3: detected capacity change from 0 to 939524096 dracut Warning: No root device "block:/dev/xvda1" found

/etc/fstab: /dev/xvda1 / ext4 defaults 1 1 ...

/boot/grub/grub.conf: title CentOS Linux 6.6 (Custom AMI, hd0) root (hd0) kernel /boot/vmlinuz-2.6.32-504.30.3.el6.i686 ro root=/dev/xvda1 rd_NO_PLYMOUTH LANG=en_US.UTF-8 KEYTABLE=de selinux=0 rdshell console=ttyS0 initrd /boot/initramfs-2.6.32-504.30.3.el6.i686.img

AWS-KERNEL: eu-west-1, EU (Ireland) region AMI Image ID 32bit (hd0): aki-68a3451f

cloud-init: 0.7.5-10.el6.centos.2.i686 using latest ec2-tools: wget http://s3.amazonaws.com/ec2-downloads/ec2-ami-tools.zip wget http://s3.amazonaws.com/ec2-downloads/ec2-api-tools.zip

I'm pretty sure that this way (changing devices to 'xvde1', and as it's described in many tutorials) worked in the past. Has there anything changed in ec2-api tools or I'm missing something else? This problem drives me crazy and wastes my time for four days. Amazon support forum (ec2) has a lot of similar boot problems, but not this case. Any advice would be greatly appreciated!!!

Blockquote

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.