1

I'm running Windows Server 2012 R2 and have a Windows 7 Professional Laptop (non virtual, all physical) that I cannot join to the domain I created.

I am trying to join the Windows 7 client to my domain but getting the DNS error about not being able to resolve the DNS name of a domain controller in the domain being joined has failed. The domain name is 'domain_name.local'. The 2012 R2 server is the domain controller with an IP address of 192.168.1.2.

  • I can ping the domain controller (DC01) with name and it returns the IPv6 address
  • I can ping the domain controllers IP address and it succeeds
  • I CANNOT ping DC01.domain_name.local

Now, I have looked on here already and tried some of the things that people have suggested in regards to this issue which are:

  • Give the Windows 7 client static IPv4 settings (IP, Subnet, Gateway)
  • Point the primary DNS of the WIN7 client to the DC
  • Flush the DNS
  • Register the DNS
  • I have taken the WIN7 client (laptop) off the WiFi and connected it via an ethernet cable
  • Created a reverse lookup zone
  • 1
    Is your client using DNS from the DC? – Falcon Momot Aug 31 '15 at 5:13
3

A Windows client doesn't need a DNS suffix in order to join an Active Directory domain. The process (for various client TCP/IP settings) is as follows:

When joining the domain using the NetBIOS name of the domain:

If the client has a DNS suffix then it issues a DNS query using it's own suffix. If the client DNS suffix matches the AD DNS suffix then a single DNS query is sufficient for the client to locate the appropriate resources. If the client receives an NXDOMAIN response because the client DNS suffix doesn't match the AD DNS suffix, then the client issues a NetBIOS name query looking for a domain controller for the NetBIOS domain name. Note that this is a broadcast query to the subnet broadcast address. If the client doesn't have a DNS suffix then it issues only a NetBIOS name query. The client has no way to issue a query using the AD DNS suffix because it isn't known to the client when attempting to join the domain using the NetBIOS name of the domain (unless the client DNS suffix matches the AD DNS suffix). The client can only use it's own DNS suffix, and failing that, fall back to issuing a NetBIOS name query.

When joining the domain using the DNS name of the domain:

If the client DNS suffix matches the AD DNS suffix then a single DNS query is sufficient for the client to locate the appropriate resources. If the client DNS suffix doesn't match the AD DNS suffix then the client issues a DNS query first using it's own suffix and upon receiving an NXDOMAIN response issues a DNS query using the AD DNS suffix. If the client doesn't have a DNS suffix then it issues a query using only the AD DNS suffix of the domain it's attempting to join. No NetBIOS query is needed in this scenario because the AD DNS suffix is known to the client.

-3

Your DHCP server probably isn't including "domain_name.local" as a search suffix. Try going to a command prompt and typing "ipconfig /all" and look near the top:

Windows IP Configuration

Host Name . . . . . . . . . . . . : SOMSYSTEMNAME
Primary Dns Suffix  . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : mydomain.net
                                   b.mydomain.net
                                   m.mydomain.net

You're going to want to see "domain_name.local" listed as either the Primary DNS Suffix or in the DNS Suffix Search List.

If it's not, you can either fix your DHCP to supply this (preferred) or manually configure it in the properties of either or both (IPv4 and IPv6) TCP/IP stacks via Control Panel. It'll be an Advanced setting in the Properties of the stacks.

  • Thank you for your reply, I tried many things including this with no luck. In the end I realised when I was getting an IPv6 address back from the ping to the DC's name, it was something to do with the manual config of the properties. I unticked IPv6 on the client and it worked! – 9kevlar3 Aug 30 '15 at 14:36
-3

I would suggest you set your DC to use IP4 first in the NIC's binding order. This assumes you prefer to use IP4 over IP6 for your network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.