1

I have logged in as Administrator to my windows 2012 server. I just installed active directory certificate services role, now I want to remove it (as this service prevents me from adding my server to a domain) but the roles are grayed out. What can I do?

3

Are you sure you're running the Remove Roles and Features wizard?

You can also try to remove the role via Powershell. Run Powershell as an Administrator then type the following in the console.

PS C:\WINDOWS\system32> Remove-WindowsFeature -Name AD-Certificate
  • Well I'm not an expert but I have used adding/removing roles many many times on windows servers 2003,2008,2012 but however this power shell solved the problem. thanks a lot – Ashkan Mobayen Khiabani Aug 30 '15 at 16:46
  • Yeah I asked the question only because I know I have accidentally used the wrong wizard before haha. I am glad the Powershell command solved your problem! – Art.Vandelay05 Aug 30 '15 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.