-1

I'm new to server configuration, I have used rented webservers a lot, but I tried venturing myself with a VPS to run my own web/email server.

All is good, I installed VestaCP to help me with dealing with everything related, and I set up the DNS records on my .ovh domain (OVH manage panel) as follows (text format, replaced Server ip for [server_ip] and domain name for [my_domain], I kept the dots after the domain name though, so you know I'm using them [eg.: domain.ovh.]):

$TTL 3600
@   IN SOA dns109.ovh.net. tech.ovh.net. (2015082409 86400 3600 3600000 300)
                        IN NS     dns109.ovh.net.
                        IN NS     ns109.ovh.net.
                        IN MX 10  [my_domain].
                        IN A      [server_ip]
                        IN TXT    "1|www.[my_domain]"
_imaps._tcp             IN SRV    0 0 993 [my_domain].
_submission._tcp        IN SRV    0 0 465 [my_domain].
ftp                     IN CNAME  [my_domain].
pop                     IN CNAME  [my_domain].
smtp                    IN SRV    0 0 25 [my_domain].
smtp                    IN SRV    0 0 587 [my_domain].
www                     IN MX 10  [my_domain].
www                     IN A      [server_ip]
www                     IN TXT    "3|welcome"
www                     IN TXT    "l|pt"

Most of the configurations are default, I only set an A record to my server ip, and as I was trying to get email to work, I set an MX record priority 10 to point to my domain, which then points to my server because of the A record (at least that is what I understand...).

As of now, the email works and I am able to send and receive email through roundcube, what I can not do is use POP3/IMAP and SMTP to use a different email client...

I never really had to change DNS settings, so I dont even know what to look for when I search for help...

If any extra information is needed, just ask for it :)

Thanks,

closed as off-topic by womble, Katherine Villyard, Wesley, HBruijn, MadHatter Aug 31 '15 at 15:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • That isn't the submission port, BTW... – womble Aug 30 '15 at 20:58
  • Sorry, what do you mean? Is that for the ` _submission._tcp` line? I didnt change that, it was automatically configured by ovh – Antero Duarte Aug 30 '15 at 21:33
  • I'm puzzled by the downvotes for this question. It's certainly a relevant question, well presented and OP seems to have done at least some basic research (for example, specifically pointing out the dots in his configuration) – Brandon Xavier Aug 31 '15 at 11:15
  • @Brandon Xavier Thank you very much for your kind comment, I quit trying to please everyone with my questions. Maybe some folk thought I should have been born knowing about this already... Anyway, great answer from you, i changed my settings, DNS propagated and everything works now :) – Antero Duarte Aug 31 '15 at 14:39
1

You didn't mention the other email client you're trying to use, but since you have some SRV records, I'll assume it supports auto discovery.

It looks like there's a little bit of confusion with some of your records.

This one is fine, although some might frown upon using a CNAME, for non-autodiscovery (i.e. you manually enter pop.my_domain in your email client for the incoming server name):

pop                     IN CNAME  [my_domain].

To make it autodiscoverable, add the second line. For SRV records, the protocol should be included in the name, and the service name should begin with an underscore ("_"):

pop                     IN CNAME   [my_domain].
_pop3._tcp                 SRV     0 1 110 [my_domain].

Per RFC-6186, _submission is used to identify your SMTP server, so these are probably serving no useful purpose (and they are missing the ._protocol):

smtp                    IN SRV    0 0 25 [my_domain].
smtp                    IN SRV    0 0 587 [my_domain].

(Edit: Although not defined in the RFC, I do see _smtp._tcp being used for this, so it's possible your client would support this.)

However, you could turn them into an A record for non-autodiscovery clients:

smtp                    IN A      [my_domain].

Unless you are sending mail to user@www.my_domain this record does nothing:

www                     IN MX 10  [my_domain].

Most of this is well described in RFC-6186

  • thank you for your answer. It enlightened me, I had no clue of what was done and what I was doing, now I understand a bit more, thanks to your link to RFC-6186. The client I intend to use is Gmail, although I never thought the client could affect how the server is configured, as there are so man different clients. SMTP works now and I can send mail through my domain, I canot receive through pop though, but I will wait for DNS propagation. Thank you – Antero Duarte Aug 31 '15 at 8:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.