0

I have a problem that's puzzling me and I can't quite put my finger on it.

We have two VMs, running Windows Server 2012 R2, both configured with Remote Desktop Services and running the RemoteApp server for our employees to connect to.

Both are configured identically, just with different programs on each. They get their GPOs from the domain server, so any changes I make in the local gpedit.msc get overwritten shortly after anyway.

One of the two servers remembers passwords after you log in for the first time, but the other does not. I can remember the password in Remote Desktop (mstsc.exe) if I uncheck "always ask for credentials", but when I try to run the deployed RemoteApps (each is its own .rdp file, as those who use RemoteApps probably know) it still prompts each time I initiate the session.

What puzzles me is that both of them have the same Group Policy settings! I also looked in Server Manager and confirmed that all the Remote Desktop Services settings matched as well... there's nothing in there telling it to not remember passwords. "Prompt for credentials on the client computer" is not configured, for example.

Any other ideas what might be causing this? We thought it might have to do with which is set as the default RemoteApp server (in Windows 8 and 10), but that did not help - even setting the second as the default (which makes it so users cannot modify or remove it from Control Panel -> RemoteApp and Desktop Connections) doesn't fix the problem, and it still prompts for a password every logon.

0

I have always had troubles saving passwords for IP address instead of hostnames. (this might not be your issues) I tried this on my Win 10 machine and it worked for me:

http://netport.org/?p=255

You can set these at the domain level as well

enter image description here

  • Mine looks exactly like that already. And we are using hostnames, not IPs. – Danny Forche Sep 1 '15 at 16:04
0

I remember that in WS2008R2 there was a checkbox in the RDSH console that was doing the same thing but without triggering the Group policy setting. In 2012 the console doesn't exist.

Please Check this policy setting, it might be causing this behaviour

Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Session Host\Security\Always prompt password upon connection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.