1

I have a problem while setting up DNS forwarding in Windows 2012 Server R2.

The local network two AD servers running DNS servers at 192.168.0.10 (AD1) and 192.168.0.11 (AD2). Both DNSes have forwarders set up, 8.8.8.8 and 8.8.4.4. The DNS entries on the network adapter for AD1 are set to 192.168.0.11 and 127.0.0.1. AD2 follows the same approach, and has 192.168.0.10 and 127.0.0.1 set up as primary and secondary DNSes on its NIC. Since this is a multihomed environment, I am leaving out the rest of the NIC configuration - I will gladly provide it if necessary.

When I try to access a "public" address (say www.google.com) from any of those servers, everything works without a glitch. However, whenever I try to ping that same address from any of the domain clients from the same local network (say at 192.168.0.20, having its DNS servers pointing at AD1 and AD2), I get

Ping request could not find host www.google.com. Please check the name and try again.

At the same time, nslookup works everywhere! Name resolution for local domain names works from all clients, so it appears that local DNSes are working, but something is wrong with the forwarding setup.

Ping works for all IP addresses, so there are no connectivity problems. When I add an external DNS (say 8.8.8.8) to the client's configuration - as a tertiary DNS - ping becomes fully functional. There has to be a better way of doing this. Without this external DNS, "No Internet access" is displayed in the "Connectivity" column next to the NIC in the Network and sharing center. This is obviously not the case - apart from not being able to resolve symbolic names, everything works.

I have tried removing the forwarders, and use only root hints, without success. I'm sure I'm missing obvious, but after spending half of day on it, I am still at the beginning.

  • 3
    Note - ping is not a DNS tool. It's an ICMP tool. For troubleshooting DNS, use something like nslookup or host. – EEAA Aug 31 '15 at 17:46
  • Agree with @EEAA. Ping isn't going to tell you what's going on with DNS. That being said; first set each DC to use itself as secondary and 127.0.0.1 as tertiary. So for each DC: partner DC for primary, itself for secondary, 127.0.0.1 for tertiary. Then use nslookup in interactive and debug mode on a client and see exactly what's happening with the queries. Post the results here. – joeqwerty Aug 31 '15 at 17:56
  • Your configuration should work. But the "multihomed" part bothers me... DCs can behave quite weirdly when multihomed. Please add details, the culprit is likely to be there. – Massimo Aug 31 '15 at 18:02
  • Yes, the multihomed part of the story was the culprit. After I posted the question here, I disabled the second NIC, double checked the configuration and it started working flawlessly. Since that second NIC is not absolutely neccessary, it will stay that way. – DenisS Sep 1 '15 at 13:33
0

Sometimes the local cache on the DNS client causes that type of problems when using ping... Try >ipconfig /flushdns on the client computer to clean up the cache right before pinging external addresses. If that doesn't work, I would suggest taking a network trace to see what's on the wire.

0

As suggested by Massimo, having a multihomed DC is never a good idea. After removing the second NIC, everything started working as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.