We have several machines exhibiting the same problem: Occasionally, the screen resolution of the machine will reset to 800x600. After the problem occurs, the only way to correct it is to reboot. If you try to reset the screen resolution in settings, etc., you don't get any errors, but the resolution doesn't change (oddly, if you select any resolution other than the previous one (which is the one that you want), it works).

This usually happens either as a result of the console being locked, or after a remote desktop session, where the machine in question was the host.

All of the machines exhibiting the problem are running Windows Vista, they have various nVidia graphics cards, and they either have a single, large monitor (27"), or dual 21" monitors. They are all various flavors of Dell workstations.

We've tried updating the video drivers to no avail. These same machines also exhibit other video problems. For example:

  • the screen sometimes goes black when Windows switches to the secure desktop (for UAC checks).

  • the screen often goes black when attempting to unlock a locked console (sometimes you can't see anything, sometimes it is all black except for password textbox, which is visible).

This has affected probably a dozen high-end workstations. Has anyone else seen this problem?


I had the screen resizing issues with Vista Ultimate x64 on an nVidia GeForce 8600 GT when the monitor came back from Power Saving mode.

What's notable about this bug is that, at least on my machine, it only started with the mid-2009 x64 drivers.

I have since upgraded to Windows 7 Ultimate x64 (yay MSDN), and the problem went away. Clearly, this isn't an option for you, but you may want to see if drivers from early 2009 exhibit the same problems.

  • This is the closest thing to an answer that I ever found -- moving to Windows 7 "fixed" it.
    – JMarsch
    Nov 28 '10 at 21:29

I've had my Dell Vista (and Windows-7) laptop and desktop behave a bit like this.

In my laptop's case, if I suspend the laptop undocked, then unsuspend docked when attached to a new monitor (or one the computer hasn't seen for a while) the video mode goes 800x600 until I define the resolution on the monitor correctly.

I would also have issues where if I suspended the laptop on a dock which was using the external monitor as the primary, when unsuspending undocked I would have a totally black screen. I would then have to type in the password to login blind. I worked out that this was because the video-display applet (either the built-in or the supplied nVidia one) only ran once the user had logged in.

Upgrading to Windows-7 and making a habit of hibernating rather than suspending turns out to be a more-or-less effective work-around, even if hibernating is much slower than suspending.

My desktop, which is an older Dell Dimension 5150, would also go all-black when the UAC popped up -- except for the UAC window. I think this was because the video chipset wasn't supported properly under Vista for Aero. Under Windows-7 it is better, but there is still a 5-second wait for the UAC to pop up, during which time the monitor is all black. I blame this on the stone-aged video chipset in this computer.

  • Hmm, I'll check in to monitor definitions. In our case, both the motherboard chipsets and the video card are relatively recent (Core 2 CPUs/chipsets, and nVidia 9x00 series video cards)
    – JMarsch
    Oct 6 '09 at 18:31
  • Well, so far so good. I installed the monitor driver on one of the machines (really not expecting much), and so far, no problems. I'm going to let it ride for a few days before I call it solved, but it looks promising.
    – JMarsch
    Oct 8 '09 at 22:38
  • Well, I'm afraid the unwanted behavior returned on my test machine today. I have no idea what is causing this.
    – JMarsch
    Oct 12 '09 at 17:39

This is not an answer, I'm afraid. Unfortunately, I don't think that any of the factors that you mentioned are relevant to the problem (from which I also suffer) -- for example, it's also been seen with ATI graphics cards, non-Dell monitors, laptops and desktops, Vista RTM, SP1, SP2, and Windows 7. There's a long thread about it here, which has been going for at least 8 months, but it has yet to be resolved :-(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.