0

I have a client XP machine that logs onto the network via dial-up connection. In the process of identifying and removing a worm on the client, the permissions for Remote Access Connection Manager got changed. Don't ask how, it is beside the point. All permissions were removed (Full, Read, etc.) for ALL users.

The service will not start (obviously), and when I right-click it in the services console, all the options at the top (Start, Stop, Pause, Restart, etc.) are grayed out. When I click Properties, I get an Access Denied, Error 5.

I have logged in as SYSTEM, and still get the same denial and error. Running SC from the command prompt will not touch it either. I have also tried starting in Safe Mode and logging on as Administrator.

File permissions for rasman.dll and rasmans.dll are set for Full for all users. It is not a file permission problem.

Bottom line: how do you reset (or else take ownership and then set) permissions for a service when no account seems to have access to it?

  • I'd start by scrapping XP and installing a modern, supported operating system. – EEAA Sep 1 '15 at 18:11
  • That is not possible on this machine. Please offer an answer to the problem, not a suggestion to do something entirely different. – ScopemeterRepair Sep 1 '15 at 18:20
  • 2
    Well, you've asked a question on a site for professionals, and continuing to rely on a very old, unsupported OS is unprofessional, so at the very least, I have to mention that it's a horrible idea to continue doing what you're doing. Since it's quite likely you'll need to re-install the OS anyway, you might as well take the opportunity to upgrade. – EEAA Sep 1 '15 at 18:22
  • So your solution is to re-install? If so, please note that as a possible answer. – ScopemeterRepair Sep 1 '15 at 18:24
0

I found the solution:

In RegEdit, navigate to HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ RasMan \ Security, and delete the "Security" item. Then reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.