2

When I run apt-get install apache2

I get some error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2 : Depends: apache2-mpm-worker (= 2.2.22-1ubuntu1.10) but it is not going to be installed or
                    apache2-mpm-prefork (= 2.2.22-1ubuntu1.10) but it is not going to be installed or
                    apache2-mpm-event (= 2.2.22-1ubuntu1.10) but it is not going to be installed or
                    apache2-mpm-itk (= 2.2.22-1ubuntu1.10) but it is not going to be installed
           Depends: apache2.2-common (= 2.2.22-1ubuntu1.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tries all known ways to solve this,try to run:

apt-get update;
apt-get upgrade;
apt-get purge apache2*

I have removed /etc/apache2 and /usr/include/apache2 directories.

I tried to change mirror server, but still nothig solve my problem, I get same error.

Ilso I try to insall manualy missing packages:

apt-get -f install apache2-mpm-worker

But now get error, that missing several packages:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2-mpm-worker : Depends: apache2.2-common (= 2.2.22-1ubuntu1.10) but it is not going to be installed
                      Depends: apache2.2-bin (= 2.2.22-1ubuntu1.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What can solve my problem, only OS reinstall ?

1
  • What version of Ubuntu?
    – Moshe Katz
    Sep 3 '15 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.