1

I have spent a full day troubleshooting this issue and am truly desperate now.

Windows 10 is my main machine, and within it, I run a Debian VM that I use as a full Linux web stack. The Linux VM runs an SVN server, which in itself works just fine. On my Windows 10 machine (local drive) I can checkout and commit. I do it with the only user that I have configured in SVN.

That's not my use case though. What I want is to use my Windows IDE to directly manipulate files on the Linux server. I access said files via a network mapping.

I've installed SAMBA on the Linux VM to make that possible. And this in itself also works. I can access the network mapping and have full control over all files on it. The authorization setup is simple: I have a group @fileadmins to which I added my personal user, root, and www-data (for Apache). To keep this situation simple, however, for now I'm doing everything under the root account.

Now for the final part: I like to put working copies on that network drive. This way I can directly manipulate the files, as well as do commits, seamlessly from Windows using TortoiseSVN. I know that this scenario is not recommended, but note that I am the only user, and this is a very efficient setup. I've been doing this for personal projects for many years, on previous servers.

For some reason, I cannot get it to work this time. Here's the error I'm getting, for example when doing a first checkout of a repos:

Can't move 'W:\jd5.svn\tmp\svn-5FDD2730' to 'W:\jd5.svn\pristine\18\185e98e0088e20d84a5dfaaee60a22f73658439a.svn-base': Access is denied.

From people with similar problems, I've learned that TortoiseSVN is creating these SVN-specific files on the fly with a specific set of very limited permissions, meaning as readonly, and with limited Linux file permissions.

Almost all answers therefore focus on configuring Samba to force higher permissions on newly created files (such as those created by TortoiseSVN). Here is my current samba config file:

[projects]
comment = web apps for users in group *fileadmins*
path = /var/www/apps
valid users = @fileadmins
create mask = 0777
directory mask = 0777
writable = yes
force create mode = 0777
force directory mode = 0777
write list = +@fileadmins
delete readonly = yes
read only = No

As you can see, I'm leaving permissions wide open, intentionally, just to get something to work. If I now from Windows create a new text document manually on the network drive, it will have the above permissions applied to them, so that works.

The files created by the TortoiseSVN client, in particular the ones it is complaining about, are as follow:

  • .svn/tmp (group: fileadmins, owner: root, permissions: 0777)
  • .svn/tmp/svn-5FDD2730 (group: root, owner: root, permissions: 0777)
  • .svn/pristine (group: fileadmins, owner: root, permissions: 0777)
  • .svn/pristine (group: fileadmins, owner: root, permissions: 0777)
  • .svn\pristine\18 (group: root, owner: root, permissions: 0777)

From the looks of it, root has full access to all files, and I'm using the network drive as user root. I assume TortoiseSVN runs under the same account.

The only weird thing about the above is that some files have root as their group. I tried to force a group via Samba settings, but that led to an issue that made the whole drive unavailable. Either way, as root is owner (as a user), I don't expect that to matter.

From my perspective, I have stretched permissions to the maximum possible, yet I still get permission errors. I am eager to learn what I am overlooking. I have had such a setup working on multiple machines for over a decade, yet am completely stuck on this one.

1

I have this problem as well, but found that if I repeat the update process a few times, eventually all files are updated. I occasionally need to do a clean up as well.

This problem started when I upgraded Tortoise from 1.7.11.xx to 1.9.0.xx

  • Thank you for your answer. I'll soon try to downgrade TortoiseSVN, to see if that makes a difference. – Ferdy Oct 26 '15 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.