1

I have a php web application and constantly throws the same error when i try to load its URL , the reason i posted here, is because i get closely to no errors from logs the only one i get in apache error logs is this.

[Sat Sep 05 09:47:44 2015] [alert] [client **.**.**.**] 
/home/domain/public_html/invoice/.htaccess: Option FollowSymlinks not allowed here

which i dont think is the problem here, cause its an alert and not an error..

server details

  • Apache version 2.2.15
  • Centos 6.7
  • PHP 5.3.3

also ls -l lists files as root:root at owner:group , the user i make changes from is not root its phoenix:phoenix, could it be a permission problem?


    # 1. To use this file, you need to be using Apache with mod_rewrite enabled.
# 2. Rename this file to .htaccess (remove .txt from the end of this file name)

Options +FollowSymlinks
  • 1
    It would help a lot if you would post your .htaccess file in the question. Have you looked at this to see if it points you in the right direction? virtualmin.com/node/24753 – Kelly Keller-Heikkila Sep 5 '15 at 15:37
  • updated with .htaccess – Gntem Sep 5 '15 at 15:45
  • @BrianKH could it be that SymLinksIfOwnerMatch restricts +FollowSymlinks since .htaccess has root:root owner/group and i believe it supposed to be phoenix:phoenix? – Gntem Sep 5 '15 at 15:51
  • Is your application using sym links? If not, you should be able to drop that option. Is your Web server running as phoenix? – Kelly Keller-Heikkila Sep 5 '15 at 16:02
  • yes it uses symlinks , i listed processess and have root /usr/sbin/httpd with child apache /usr/sbin/httpd and child phoenix /usr/bin/php-cgi so it looks like php-cgi is from phoenix user? isn't that the way it should be? – Gntem Sep 5 '15 at 16:51
3

Can you look or make changes to the apache config?
If so you could make sure that AllowOverride All is set for your Virtual Host or Directory.

|improve this answer|||||
  • AllowOverride is set us AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch changing or removing SymLinksIfOwnerMatch would it make a difference? – Gntem Sep 5 '15 at 17:48
  • Try FollowSymlinks instead of SymLinksIfOwnerMatch. – Eddie Dunn Sep 5 '15 at 17:51
  • yeap that worked out pretty well, script is executing perfectly , imo will stop using apache after this – Gntem Sep 5 '15 at 17:58
  • Apache is like a girlfriend. Trials and errors before being able to appreciate her – Razique Sep 7 '15 at 21:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.