1

After installing pure-ftpd and adding a user using the command:

pure-pw useradd <user> -u <user> -d /var/www/domain -f /var/pure-ftpd/pureftpd.passwd

pure-ftp asks me for a new password for the user. However, after logging in the user via ftp I can only do this using his linux password (and not the one set above). More, user is directed to his home at /home/ rather then given /var/www/domain.

Can someone help?

0

Maybe you've forgotten to set your puredb path in your pure-ftpd.conf file or specify the auth mode in the launching command using the -l option (see the man page for pure-ftpd).

1

If you want to add user home as root(/) directory, just change the below option in pure-ftpd.conf which is available in /etc/pure-ftpd dir.

# Cage in every user in his home directory
# YES - User dir as root(/) directory
# NO  - No restriction 

ChrootEveryone YES

More details are explained in SUSE11 FTP general settings

0

run

ln -s /etc/pure-ftpd/conf/PureDB /etc/pure-ftpd/auth/60PureDB

to enable internal authentication method prior to UNIX authentication and PAM authentication

see this page for details

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.