4

I'm using UltraEdit (Windows) to edit files on remote SFTP servers. For some reason I can no longer connect to one of those servers.

Here's what was changed:

  1. The server was moved (and updated) from one VM to another - usually this only prompts about rsa fingerprint changed and then works with no other changes needed.
  2. I've been trying out different software for mapping SSH/SFTP as a Windows drives.

The connection seemed to break after mapping the server in ExpanDrive (I'm almost certain that I continued working on the server after it was moved and updated).

Some points worth noting:

  • The problem only exists for this particular server as I can still connect to the other VMs (which are in the same network and have the same requirements to log in).
  • I can still connect to the server with PuTTY (after updating rsa fingerprint)
  • FileZilla SFTP also works as well
  • Some driver mappers work (SFTP Net Drive, sshfs), some don't (ExpanDrive, WebDrive)
  • I've removed all entries containing the server name in the registry.

Faulty server info

  • Linux titan 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u3 (2015-08-04) - x86_64 GNU/Linux
  • Distributor ID: Debian
  • Description: Debian GNU/Linux 8.1 (jessie)
  • Release: 8.1
  • Codename: jessie

Info from working server

  • Linux ymer 3.2.0-4-amd64 #1 SMP Debian 3.2.68-1+deb7u1 x86_64 GNU/Linux
  • Distributor ID: Debian
  • Description: Debian GNU/Linux 7.8 (wheezy)
  • Release: 7.8
  • Codename: wheezy

Any idea what could be causing the connection issue in UltraEdit/drive mappers?

  • Do you perhaps get some kind of error? Are you trying to use diffie-hellman group exchange instead of group 14? – Falcon Momot Sep 7 '15 at 7:44
  • ExpanDrive has magically started working. WebDrive claims my username/password credentials are wrong and UltraEdit immediately shows error connecting, no error message (also when using the SSH console). So TL:DR: No error message (that I can find). How can I check which diffie-hellman the servers use? – Woodgnome Sep 7 '15 at 8:01
  • It's which key exchange method the clients specify that counts, so it depends on the client. Newer versions of openssh choke if you try to negotiate DH group exchange. – Falcon Momot Sep 7 '15 at 8:03
0

Found out that my home computer has the same issue and I definitely did not mess around with SSH drive mappers there, so the issue had to be related to the server upgrade.

I am running UltraEdit v20.00 - tried running a trial of v22.10 which solved the issue.

I assume there are some SSH changes in the newer Debian version which are not supported by UltraEdit v20.00, but fixed in a later version (probably v21.30, see http://www.ultraedit.com/products/ultraedit/latest-changes.html "...improvements and fixes to the following: FTP/SFTP").

Most likely the same issue that prevents me from mapping drives in certain applications.

0

I had a similar issue whereby Filezila could connect to my server, but my old copy of WebDrive couldn't.

Looking at the server logs in /var/log/auth.log I could see this error message:

sshd[1345]: Unable to negotiate with x.x.x.x port 54862: no matching cipher found. Their offer: aes256-cbc,twofish256-cbc,twofish -cbc,aes128-cbc,twofish128-cbc,blowfish-cbc,3des-cbc,arcfour,cast128-cbc [preaut h]

I solved this by enabling those legacy ciphers in sshd_config, but this was only a development server, I wouldn't recommend that for a production server.

-1

Hmm dont know if that would help you or not but I started using SysaxAutomation. They have a server modul and a script editor which comes with SFTP and anything you could do with FTP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.