7

I am working with SaltStack on Windows minions (Linux master). I have written a simple .sls file which copies a hello-world.txt at C:/hello_world.txt. I have also written my top.sls and configure my file_roots. Minions keys have been accepted (and test.ping is working).

My current problem is when I call (on the master):

salt 'my_minion' state.highstate

I get a:

Minion did not return. [no response]

Whereas when I try (on the minion):

salt-call state.highstate

Everything works fine (The file is copied). I have tried to add the -l debug option on the master but I don't get something interesting.

Any tips for debugging?

4

Try increasing the timeout with -t 300 or similar. When I first started working with salt, I found that highstates frequently take longer than the default 5 second timeout.

If that helps, you can change the default timeout with timeout: <whatever> in the master config file.

3
  • It solved my problem, thx for the tip.
    – MarAja
    Sep 9 '15 at 9:03
  • 1
    The salt command, unfortunately, can't seem to tell the difference between "minion is down" and "job is taking a long time." Even if a job times out, as long as the connection is working it's typically still running, you just won't see the results on the command line.
    – Andrew
    Sep 9 '15 at 14:40
  • 2
    The problem isn't that the salt client (run on the master) is not waiting long enough, it's that the response the minion returns is dropped on the floor. The salt command line client periodically polls to see if the job is done but the job never completes, as far as it is concerned. This may be a bug in 2015.5.3 specifically. Jan 8 '16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.