0

I cleared a server with some shells uploaded with the help of joomla 1.5. I managed to clear the shells but on closer inspection the Apache runs every php file script like: anything.php.anything with the condition that .php exists in filename.

The httpd conf files are intact and without AddType application and there is no htaccess file.

Any idea from where to change this behavior?

System: Linux 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:52:25 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

  • Have you checked about mod_mime? – WhiteWinterWolf Sep 8 '15 at 10:45
  • mod_mime is enabled and looks fine. Any config files to check for? – calculataur Sep 8 '15 at 10:57
  • @calculataur: If your issue is solved, could you put your solution in an answer and mark it as a good answer instead of updating the question? It would be interesting also if you could tell the value before modification so your post could serve as a reference telling the initial configuration, the issue caused by it and the corresponding solution. Thanks! – WhiteWinterWolf Sep 9 '15 at 14:36
1

RESOLVED by modifying php handler:

<FilesMatch \.php$>
    SetHandler php5-script
</FilesMatch> 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.